Gentoo 2477 Published by

The following three security updates are available for Gentoo Linux:

[ GLSA 202402-04 ] GNAT Ada Suite: Remote Code Execution
[ GLSA 202402-02 ] SDDM: Privilege Escalation
[ GLSA 202402-03 ] QtGui: Multiple Vulnerabilities




[ GLSA 202402-04 ] GNAT Ada Suite: Remote Code Execution


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202402-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: GNAT Ada Suite: Remote Code Execution
Date: February 03, 2024
Bugs: #787440
ID: 202402-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in GNAT Ada Suite which can lead to
remote code execution.

Background
==========

The GNAT Ada Suite is an Ada development environment.

Affected packages
=================

Package Vulnerable Unaffected
---------------------- ------------ ------------
dev-ada/gnat-suite-bin < 2019-r2 Vulnerable!

Description
===========

A vulnerability has been discovered in GNAT Ada Suite. Please review the
CVE identifier referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo has discontinued support for GNAT Ada Suite. We recommend that
users unmerge it:

# emerge --ask --depclean "dev-ada/gnat-suite-bin"

References
==========

[ 1 ] CVE-2020-27619
https://nvd.nist.gov/vuln/detail/CVE-2020-27619

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202402-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



[ GLSA 202402-02 ] SDDM: Privilege Escalation


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202402-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: SDDM: Privilege Escalation
Date: February 03, 2024
Bugs: #753104
ID: 202402-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability has been discovered in SDDM which can lead to privilege
escalation.

Background
=========
SDDM is a modern display manager for X11 and Wayland sessions aiming to
be fast, simple and beautiful. It uses modern technologies like QtQuick,
which in turn gives the designer the ability to create smooth, animated
user interfaces.

Affected packages
================
Package Vulnerable Unaffected
------------- ------------ ------------
x11-misc/sddm < 0.18.1-r6 >= 0.18.1-r6

Description
==========
A vulnerability has been discovered in SDDM. Please review the CVE
identifier referenced below for details.

Impact
=====
SDDM passes the -auth and -displayfd command line arguments when
starting the Xserver. It then waits for the display number to be
received from the Xserver via the `displayfd`, before the Xauthority
file specified via the `-auth` parameter is actually written. This
results in a race condition, creating a time window in which no valid
Xauthority file is existing while the Xserver is already running.

The X.Org server, when encountering a non-existing, empty or
corrupt/incomplete Xauthority file, will grant any connecting client
access to the Xorg display. A local unprivileged attacker can thus
create an unauthorized connection to the Xserver and grab e.g. keyboard
input events from other legitimate users accessing the Xserver.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All SDDM users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-misc/sddm-0.18.1-r6"

References
=========
[ 1 ] CVE-2020-28049
https://nvd.nist.gov/vuln/detail/CVE-2020-28049

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202402-02

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



[ GLSA 202402-03 ] QtGui: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202402-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: QtGui: Multiple Vulnerabilities
Date: February 03, 2024
Bugs: #808531, #907119
ID: 202402-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in QtGui which can lead to
remote code execution.

Background
==========

QtGui is a module for the Qt toolkit.

Affected packages
=================

Package Vulnerable Unaffected
------------ ------------ ------------
dev-qt/qtgui < 5.15.9-r1 >= 5.15.9-r1

Description
===========

Multiple vulnerabilities have been discovered in QtGui. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All QtGui users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-qt/qtgui-5.15.9-r1"

References
==========

[ 1 ] CVE-2021-38593
https://nvd.nist.gov/vuln/detail/CVE-2021-38593
[ 2 ] CVE-2023-32763
https://nvd.nist.gov/vuln/detail/CVE-2023-32763

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202402-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5