Gentoo 2479 Published by

A Lua security update has been released for Gentoo Linux.



GLSA 202305-23 : Lua: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202305-23
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Lua: Multiple Vulnerabilities
Date: May 03, 2023
Bugs: #837521, #831053, #520480
ID: 202305-23

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Lua, the worst of which
could result in arbitrary code execution.

Background
==========

Lua is a powerful, efficient, lightweight, embeddable scripting
language. It supports procedural programming, object-oriented
programming, functional programming, data-driven programming, and data
description.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
dev-lang/lua:0 *
dev-lang/lua:5.1 =5.1.5-r200:5.1
dev-lang/lua:5.2 =5.2.3:5.2
dev-lang/lua:5.4 =5.4.4-r103:5.4

Description
===========

Multiple vulnerabilities have been discovered in Lua. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Lua 5.1 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/lua-5.1.5-r200"

All Lua 5.3 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/lua-5.2.3"

All Lua 5.4 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/lua-5.4.4-r103"

References
==========

[ 1 ] CVE-2014-5461
  https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5461
[ 2 ] CVE-2021-44647
  https://nvd.nist.gov/vuln/detail/CVE-2021-44647
[ 3 ] CVE-2022-28805
  https://nvd.nist.gov/vuln/detail/CVE-2022-28805

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202305-23

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
  https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

  https://creativecommons.org/licenses/by-sa/2.5