Gentoo 2486 Published by

A Mozilla Network Security Service (NSS) security update has been released for Gentoo Linux.



GLSA 202212-05 : Mozilla Network Security Service (NSS): Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202212-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Mozilla Network Security Service (NSS): Multiple Vulnerabilities
Date: December 19, 2022
Bugs: #827946, #836386, #848984, #877169
ID: 202212-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been discovered in NSS, the worst of which
could result in arbitrary code execution.

Background
=========
The Mozilla Network Security Service is a library implementing security
features like SSL v.2/v.3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12,
S/MIME and X.509 certificates.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/nss < 3.79.2 >= 3.79.2

Description
==========
Multiple vulnerabilities have been discovered in Mozilla Network
Security Service (NSS). Please review the CVE identifiers referenced
below for details.

Impact
=====
Please review the referenced CVE identifiers for details.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Mozilla Network Security Service (NSS) users should upgrade to the
latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">?v-libs/nss-3.79.2"

References
=========
[ 1 ] CVE-2021-43527
  https://nvd.nist.gov/vuln/detail/CVE-2021-43527
[ 2 ] CVE-2022-1097
  https://nvd.nist.gov/vuln/detail/CVE-2022-1097
[ 3 ] CVE-2022-3479
  https://nvd.nist.gov/vuln/detail/CVE-2022-3479
[ 4 ] MFSA-2021-51

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202212-05

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
  https://bugs.gentoo.org.

License
======
Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

  https://creativecommons.org/licenses/by-sa/2.5