Gentoo 2485 Published by

A PostgreSQL security update has been released for Gentoo Linux.



GLSA 202211-04 : PostgreSQL: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202211-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: PostgreSQL: Multiple Vulnerabilities
Date: November 19, 2022
Bugs: #793734, #808984, #823125, #865255
ID: 202211-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been found in PostgreSQL, the worst of
which could result in remote code execution.

Background
=========
PostgreSQL is an open source object-relational database management
system.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
dev-db/postgresql < 10.22 >= 10.22:10
< 11.17:11 >= 11.17:11
< 12.12:12 >= 12.12:12
< 13.8:13 >= 13.8:13
< 14.5:14 >= 14.5

Description
==========
Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
=====
Please review the referenced CVE identifiers for details.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All PostgreSQL 10.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/postgresql-10.22:10"

All PostgreSQL 11.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/postgresql-11.17:11"

All PostgreSQL 12.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/postgresql-12.12:12"

All PostgreSQL 13.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/postgresql-13.8:13"

All PostgreSQL 14.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/postgresql-14.5:14"

References
=========
[ 1 ] CVE-2021-3677
  https://nvd.nist.gov/vuln/detail/CVE-2021-3677
[ 2 ] CVE-2021-23214
  https://nvd.nist.gov/vuln/detail/CVE-2021-23214
[ 3 ] CVE-2021-23222
  https://nvd.nist.gov/vuln/detail/CVE-2021-23222
[ 4 ] CVE-2021-32027
  https://nvd.nist.gov/vuln/detail/CVE-2021-32027
[ 5 ] CVE-2021-32028
  https://nvd.nist.gov/vuln/detail/CVE-2021-32028
[ 6 ] CVE-2022-1552
  https://nvd.nist.gov/vuln/detail/CVE-2022-1552
[ 7 ] CVE-2022-2625
  https://nvd.nist.gov/vuln/detail/CVE-2022-2625

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202211-04

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
  https://bugs.gentoo.org.

License
======
Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

  https://creativecommons.org/licenses/by-sa/2.5