Debian 10020 Published by

Updated FontForge packages are available for Debian GNU/Linux 10 LTS to address multiple vulnerabilities:

[DLA 3754-1] fontforge security update




[DLA 3754-1] fontforge security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3754-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Adrian Bunk
March 08, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : fontforge
Version : 1:20170731~dfsg-1+deb10u1
CVE ID : CVE-2020-5395 CVE-2020-5496 CVE-2024-25081 CVE-2024-25082
Debian Bug : 948231 1064967

Multiple vulnerabilities have been fixed in the font editor FontForge.

CVE-2020-5395

Use-after-free in SFD_GetFontMetaData()

CVE-2020-5496

Buffer overflow in Type2NotDefSplines()

CVE-2024-25081

Spline Font command injection via crafted filenames

CVE-2024-25082

Spline Font command injection via crafted archives or compressed files

For Debian 10 buster, these problems have been fixed in version
1:20170731~dfsg-1+deb10u1.

We recommend that you upgrade your fontforge packages.

For the detailed security status of fontforge please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/fontforge

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS