Fedora Linux 8617 Published by

A vim security update has been released for Fedora 36.



SECURITY: Fedora 36 Update: vim-9.0.1407-1.fc36


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2023-030318ca00
2023-04-02 01:33:23.803299
--------------------------------------------------------------------------------

Name : vim
Product : Fedora 36
Version : 9.0.1407
Release : 1.fc36
URL :   http://www.vim.org/
Summary : The VIM editor
Description :
VIM (VIsual editor iMproved) is an updated and improved version of the
vi editor. Vi was the first real screen-based editor for UNIX, and is
still very popular. VIM improves on vi by adding new features:
multiple windows, multi-level undo, block highlighting and more.

--------------------------------------------------------------------------------
Update Information:

Security fixes for CVE-2023-1175, CVE-2023-1170, CVE-2023-1264, CVE-2023-0512,
CVE-2023-1355 ---- The newest upstream patchlevel 1367 Security fix for
CVE-2023-1127
--------------------------------------------------------------------------------
ChangeLog:

* Thu Mar 16 2023 Zdenek Dohnal - 2:9.0.1407-1
- patchlevel 1407
* Tue Mar 14 2023 Zdenek Dohnal - 2:9.0.1403-1
- patchlevel 1403
* Thu Mar 2 2023 Zdenek Dohnal - 2:9.0.1367-1
- patchlevel 1367
* Fri Feb 17 2023 Zdenek Dohnal - 2:9.0.1314-1
- patchlevel 1314
--------------------------------------------------------------------------------
References:

[ 1 ] Bug #2165798 - CVE-2023-0512 vim: divide by zero in adjust_skipcol() at move.ca
  https://bugzilla.redhat.com/show_bug.cgi?id=2165798
[ 2 ] Bug #2174662 - CVE-2023-1127 vim: Divide By Zero in vim/vim
  https://bugzilla.redhat.com/show_bug.cgi?id=2174662
[ 3 ] Bug #2176413 - CVE-2023-1264 vim: NULL pointer dereference issue in utfc_ptr2len
  https://bugzilla.redhat.com/show_bug.cgi?id=2176413
[ 4 ] Bug #2176457 - CVE-2023-1175 vim: Incorrect Calculation of Buffer Size
  https://bugzilla.redhat.com/show_bug.cgi?id=2176457
[ 5 ] Bug #2176462 - CVE-2023-1170 vim: Heap-based Buffer Overflow
  https://bugzilla.redhat.com/show_bug.cgi?id=2176462
[ 6 ] Bug #2179911 - CVE-2023-1355 vim: null pointer dereference in class_object_index at vim9class.c
  https://bugzilla.redhat.com/show_bug.cgi?id=2179911
--------------------------------------------------------------------------------

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2023-030318ca00' at the command
line. For more information, refer to the dnf documentation available at
  http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
  https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________