Oracle Linux 6188 Published by

A mariadb:10.3 security, bug fix, and enhancement update has been released for Oracle Linux 8.



ELSA-2023-5259 Moderate: Oracle Linux 8 mariadb:10.3 security, bug fix, and enhancement update


Oracle Linux Security Advisory ELSA-2023-5259

http://linux.oracle.com/errata/ELSA-2023-5259.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
galera-25.3.37-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.x86_64.rpm
mariadb-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-backup-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-common-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-devel-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-embedded-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-embedded-devel-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-errmsg-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-gssapi-server-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-oqgraph-engine-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-server-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-server-galera-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-server-utils-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm
mariadb-test-10.3.39-1.module+el8.8.0+21165+f6462f70.x86_64.rpm

aarch64:
galera-25.3.37-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.aarch64.rpm
mariadb-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-backup-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-common-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-devel-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-embedded-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-embedded-devel-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-errmsg-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-gssapi-server-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-oqgraph-engine-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-server-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-server-galera-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-server-utils-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm
mariadb-test-10.3.39-1.module+el8.8.0+21165+f6462f70.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//galera-25.3.37-1.module+el8.8.0+21165+f6462f70.src.rpm
http://oss.oracle.com/ol8/SRPMS-updates//Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.src.rpm
http://oss.oracle.com/ol8/SRPMS-updates//mariadb-10.3.39-1.module+el8.8.0+21165+f6462f70.src.rpm

Related CVEs:

CVE-2022-32084
CVE-2022-32091
CVE-2022-38791
CVE-2022-47015

Description of changes:

galera
[25.3.37-1]
- Rebase to 25.3.37

Judy
[1.0.5-18.0.1]
- Rebuild [Orabug: 31667911]

mariadb
[3:10.3.39-1]
- [MariaDB 10.3.32] socat: E Failed to set SNI host "" (SST failure)
- Rebase to 10.3.39
- CVEs fixed:
CVE-2022-47015, CVE-2018-25032, CVE-2022-32091, CVE-2022-32084