Debian 9902 Published by

An ncurses security update has been released for Debian GNU/Linux 8 and 9 Extended LTS to address several issues.



ELA-643-1 ncurses security update

Package ncurses
Version 5.9+20140913-1+deb8u4 (jessie), 6.0+20161126-1+deb9u3 (stretch)
Related CVEs CVE-2018-19211 CVE-2019-17594 CVE-2019-17595 CVE-2022-29458

Several issues have been found in ncurses, a shared libraries for terminal handling. These issues are about out-of-bounds reads, missing checks for strange input and NULL pointer dereferencing in different parts of the library.

For Debian 8 jessie, these problems have been fixed in version 5.9+20140913-1+deb8u4.

For Debian 9 stretch, these problems have been fixed in version 6.0+20161126-1+deb9u3.

We recommend that you upgrade your ncurses packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/

  ELA-643-1 ncurses security update