Debian 9982 Published by

A dino-im security update has been released for Debian GNU/Linux 11 to address an insufficient message sender validation that may result in manipulation of entries in the personal bookmark store without user interaction via a specially crafted message.



DSA 5379-1: dino-im security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-5379-1 security@debian.org
  https://www.debian.org/security/ Salvatore Bonaccorso
March 27, 2023   https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : dino-im
CVE ID : CVE-2023-28686
Debian Bug : 1033370

Kim Alvefur discovered that insufficient message sender validation in
dino-im, a modern XMPP/Jabber client, may result in manipulation of
entries in the personal bookmark store without user interaction via a
specially crafted message. Additionally an attacker can take advantage
of this flaw to change how group chats are displayed or force a user to
join or leave an attacker-selected groupchat.

For the stable distribution (bullseye), this problem has been fixed in
version 0.2.0-3+deb11u1.

We recommend that you upgrade your dino-im packages.

For the detailed security status of dino-im please refer to its security
tracker page at:
  https://security-tracker.debian.org/tracker/dino-im

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://www.debian.org/security/