Debian 9820 Published by

An emacs security update has been released for Debian GNU/Linux 11 to address missing input sanitizing.



DSA 5360-1: emacs security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-5360-1 security@debian.org
  https://www.debian.org/security/ Moritz Muehlenhoff
February 23, 2023   https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : emacs
CVE ID : CVE-2022-48337 CVE-2022-48338 CVE-2022-48339

Xi Lu discovered that missing input sanitising in Emacs (in etags, the
Ruby mode and htmlfontify) could result in the execution of arbitrary
shell commands.

For the stable distribution (bullseye), these problems have been fixed in
version 1:27.1+1-3.1+deb11u2.

We recommend that you upgrade your emacs packages.

For the detailed security status of emacs please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/emacs

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://www.debian.org/security/