Debian 10020 Published by

A lwip security update has been released for Debian GNU/Linux 10 LTS to address a buffer overflow vulnerability.



[SECURITY] [DLA 3655-1] lwip security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3655-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Tobias Frost
November 18, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : lwip
Version : 2.0.3-3+deb10u2
CVE ID : CVE-2020-22283
Debian Bug : 991646

A buffer overflow vulnerability has been found in lwip, a small independent
implementation of the TCP/IPv4/IPv6 protocol suite, which allows an attacker
to access information via a crafted ICMPv6 package. This vulnerability
has been assigned CVE-2020-22283.

For Debian 10 buster, this problem has been fixed in version
2.0.3-3+deb10u2.

We recommend that you upgrade your lwip packages.

For the detailed security status of lwip please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/lwip

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS