Debian 9944 Published by

A gsl security update has been released for Debian GNU/Linux 10 LTS to address a buffer overflow.



[SECURITY] [DLA 3576-1] gsl security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3576-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Markus Koschany
September 21, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : gsl
Version : 2.5+dfsg-6+deb10u1
CVE ID : CVE-2020-35357

A buffer overflow can occur when calculating the quantile value using the
Statistics Library of GSL (GNU Scientific Library). Processing a
maliciously crafted input data for gsl_stats_quantile_from_sorted_data of
the library may lead to unexpected application termination or arbitrary
code execution.

For Debian 10 buster, this problem has been fixed in version
2.5+dfsg-6+deb10u1.

We recommend that you upgrade your gsl packages.

For the detailed security status of gsl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gsl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS