Debian 9810 Published by

A qpdf security update has been released for Debian GNU/Linux 10 LTS to address several issues that enable remote attackers to execute arbitrary code or create recursive calls for a long time.



[SECURITY] [DLA 3548-1] qpdf security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3548-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Thorsten Alteholz
August 29, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : qpdf
Version : 8.4.0-2+deb10u1
CVE ID : CVE-2018-18020 CVE-2021-25786 CVE-2021-36978

Several issues have been found in qpdf, a package with tools for
transforming and inspecting PDF files.
Crafted files may enable remote attackers to execute arbitrary code or
create recursive calls for a long time, which causes a denial of service.
Further a heap-based buffer overflow might occur when a certain downstream
write fails.

For Debian 10 buster, these problems have been fixed in version
8.4.0-2+deb10u1.

We recommend that you upgrade your qpdf packages.

For the detailed security status of qpdf please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/qpdf

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS