Debian 9812 Published by

An openssh security update has been released for Debian GNU/Linux 10 LTS to address an issue that results in incorrectly handled loading certain PKCS#11 providers.



[SECURITY] [DLA 3532-1] openssh security update


- -----------------------------------------------------------------------
Debian LTS Advisory DLA-3532-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Utkarsh Gupta
August 17, 2023 https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package : openssh
Version : 1:7.9p1-10+deb10u3
CVE ID : CVE-2023-38408
Debian Bug : 1042460

It was discovered that OpenSSH incorrectly handled loading certain
PKCS#11 providers. If a user forwarded their ssh-agent to an untrusted
system, a remote attacker could possibly use this issue to load
arbitrary libraries from the user’s system and execute arbitrary code.

In addition to the above security issue, this update also fixed
another bug - bad interaction between the ssh_config ConnectTimeout
and ConnectionAttempts directives - connection attempts after the
first attempt were ignoring the requested timeout. More details about
this can be found at https://bugzilla.mindrot.org/show_bug.cgi?id=2918.

For Debian 10 buster, this problem has been fixed in version
1:7.9p1-10+deb10u3.

We recommend that you upgrade your openssh packages.

For the detailed security status of openssh please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/openssh

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS