Debian 9821 Published by

A bouncycastle security update has been released for Debian GNU/Linux 10 LTS to address a potential LDAP injection vulnerability.



[SECURITY] [DLA 3514-1] bouncycastle security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3514-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Chris Lamb
August 02, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : bouncycastle
Version : 1.60-1+deb10u1
CVE ID : CVE-2023-33201
Debian Bug : 1040050

It was discovered that there was a protential LDAP injection
vulnerability in Bouncy Castle, a cryptographic library for Java.
During the certificate validation process, bouncycastle used the
certificate's "Subject Name" into an LDAP search filter without any
escaping.

For Debian 10 buster, this problem has been fixed in version
1.60-1+deb10u1.

We recommend that you upgrade your bouncycastle packages.

For the detailed security status of bouncycastle please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/bouncycastle

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS