Debian 9982 Published by

A ruby-doorkeeper security update has been released for Debian GNU/Linux 10 LTS to address an issue that can result in impersonation of public clients.



[SECURITY] [DLA 3494-1] ruby-doorkeeper security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3494-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Chris Lamb
July 12, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : ruby-doorkeeper
Version : 4.4.2-1+deb10u1
CVE ID : CVE-2023-34246
Debian Bug : 1038950

It was discovered that there was an issue in ruby-doorkeeper, a
OAuth2 provider for Ruby on Rails applications. Doorkeeper
automatically processed authorization requests without user consent
for public clients that have been previously approved, but public
clients are inherently vulnerable to impersonation as their identity
cannot be assured.

For Debian 10 buster, this problem has been fixed in version
4.4.2-1+deb10u1.

We recommend that you upgrade your ruby-doorkeeper packages.

For the detailed security status of ruby-doorkeeper please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ruby-doorkeeper

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS