Debian 9810 Published by

A erlang security update has been released for Debian GNU/Linux 10 LTS to address a client authentication bypass vulnerability.



[SECURITY] [DLA 3491-1] erlang security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3491-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Markus Koschany
July 11, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : erlang
Version : 1:22.2.7+dfsg-1+deb10u1
CVE ID : CVE-2022-37026
Debian Bug : 1024632

A Client Authentication Bypass vulnerability has been discovered in the
concurrent, real-time, distributed functional language Erlang. Impacted are
those who are running an ssl/tls/dtls server using the ssl application
either directly or indirectly via other applications. Note that the
vulnerability only affects servers that request client certification, that
is sets the option {verify, verify_peer}.

Additionally the source package elixir-lang has been rebuilt against the new
erlang version. The rabbitmq-server package was upgraded to version 3.8.2 to
fix an incompatibility with Erlang 22.

For Debian 10 buster, this problem has been fixed in version
1:22.2.7+dfsg-1+deb10u1.

We recommend that you upgrade your erlang packages.

For the detailed security status of erlang please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/erlang

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS