Debian 9812 Published by

An owslib security update has been released for Debian GNU/Linux 10 LTS to address an issue that could lead to arbitrary file reads from an attacker-controlled XML payload.



[SECURITY] [DLA 3470-1] owslib security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3470-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Adrian Bunk
June 25, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : owslib
Version : 0.17.1-1+deb10u1
CVE ID : CVE-2023-27476
Debian Bug : 1034182

In OWSLib, a Python client library for Open Geospatial web services,
the XML parser did not disable entity resolution which could lead to
arbitrary file reads from an attacker-controlled XML payload.

For Debian 10 buster, this problem has been fixed in version
0.17.1-1+deb10u1.

We recommend that you upgrade your owslib packages.

For the detailed security status of owslib please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/owslib

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS