Debian 9821 Published by

A golang-websocket security update has been released for Debian GNU/Linux 10 LTS to address an integer overflow vulnerability.



DLA 3420-1: golang-websocket security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3420-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Markus Koschany
May 14, 2023   https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : golang-websocket
Version : 1.4.0-1+deb10u1
CVE ID : CVE-2020-27813

An integer overflow vulnerability exists in golang-websocket, a Go package
implementing the WebSocket protocol connection. An attacker would use this flaw
to cause a denial of service attack on an HTTP Server allowing websocket
connections.

The following reverse-dependencies have been rebuilt against the new golang-
websocket version: hugo and gitlab-workhorse

For Debian 10 buster, this problem has been fixed in version
1.4.0-1+deb10u1.

We recommend that you upgrade your golang-websocket packages.

For the detailed security status of golang-websocket please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/golang-websocket

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS