Debian 9819 Published by

A duktape security update has been released for Debian GNU/Linux 10 LTS to address an issue where a specially crafted JS file could result in a SEGV due to reaching some stack limits.



DLA 3378-1: duktape security update



- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3378-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Thorsten Alteholz
April 01, 2023   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : duktape
Version : 2.3.0-1+deb10u1
CVE ID : CVE-2021-46322

An issue has been found in duktape, an embeddable Javascript engine.
It was discovered that a special crafted js file could result in a SEGV
due to reaching some stack limits.

For Debian 10 buster, this problem has been fixed in version
2.3.0-1+deb10u1.

We recommend that you upgrade your duktape packages.

For the detailed security status of duktape please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/duktape

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS