Debian 9819 Published by

A libmicrohttpd security update has been released for Debian GNU/Linux 10 LTS to address an issue that results in an out-of-bounds read.



DLA 3374-1: libmicrohttpd security update



- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3374-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Thorsten Alteholz
March 30, 2023   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : libmicrohttpd
Version : 0.9.62-1+deb10u1
CVE ID : CVE-2023-27371

An issue has been found in linmicrohttpd, a library embedding HTTP server
functionality. Parsing crafted POST requests result in an out of bounds
read, which might cause a DoS (Denial of Service).

For Debian 10 buster, this problem has been fixed in version
0.9.62-1+deb10u1.

We recommend that you upgrade your libmicrohttpd packages.

For the detailed security status of libmicrohttpd please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/libmicrohttpd

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS