Debian 9813 Published by

A redis security update has been released for Debian GNU/Linux 10 LTS to address a potential remote denial of service vulnerability.



DLA 3361-1: redis security update



- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3361-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Chris Lamb
March 13, 2023   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : redis
Version : 5:5.0.14-1+deb10u3
CVE ID : CVE-2022-36021

It was discovered that there was a potential remote denial of service
vulnerability in redis, a popular key-value database.

Authenticated users could have used string matching commands (like
`SCAN` or `KEYS`) with a specially crafted pattern to trigger a
denial-of-service attack, causing it to hang and consume 100% CPU
time.

For Debian 10 buster, this problem has been fixed in version
5:5.0.14-1+deb10u3.

We recommend that you upgrade your redis packages.

For the detailed security status of redis please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/redis

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS