Debian 9822 Published by

A libgit2 security update has been released for Debian GNU/Linux 10 LTS to address a vulnerability.



DLA 3340-1: libgit2 security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3340-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Tobias Frost
February 23, 2023   https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : libgit2
Version : 0.27.7+dfsg.1-0.2+deb10u1
CVE ID : CVE-2020-12278 CVE-2020-12279 CVE-2023-22742
Debian Bug : 1029368

A vulnerability have been found in libgit2, a cross-platform, linkable
library implementation of Git, which may result in remote code execution
when cloning a repository on a NTFS-like filesystem or man-in-the-middle
attacks due to improper verification of cryptographic Signature.

CVE-2020-12278

An issue was discovered in libgit2 before 0.28.4 and 0.9x before
0.99.0. path.c mishandles equivalent filenames that exist because of
NTFS Alternate Data Streams. This may allow remote code execution when
cloning a repository.

CVE-2020-12279

An issue was discovered in libgit2 before 0.28.4 and 0.9x before
0.99.0. checkout.c mishandles equivalent filenames that exist because
of NTFS short names. This may allow remote code execution when cloning a
repository

CVE-2023-22742

libgit2 is a cross-platform, linkable library implementation of Git.
When using an SSH remote with the optional libssh2 backend, libgit2 does
not perform certificate checking by default. Prior versions of libgit2
require the caller to set the `certificate_check` field of libgit2's
`git_remote_callbacks` structure - if a certificate check callback is
not set, libgit2 does not perform any certificate checking. This means
that by default - without configuring a certificate check callback,
clients will not perform validation on the server SSH keys and may be
subject to a man-in-the-middle attack.

For Debian 10 buster, these problems have been fixed in version
0.27.7+dfsg.1-0.2+deb10u1.

We recommend that you upgrade your libgit2 packages.

For the detailed security status of libgit2 please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/libgit2

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS