Debian 9810 Published by

A haproxy security update has been released for Debian GNU/Linux 10 LTS to address a security vulnerability that may result in denial of service, or bypass of access controls and routing rules via specially crafted requests.



DLA 3318-1: haproxy security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3318-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Markus Koschany
February 14, 2023   https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : haproxy
Version : 1.8.19-1+deb10u4
CVE ID : CVE-2023-25725

A security vulnerability was discovered in HAProxy, a fast and reliable
load balancing reverse proxy, which may result in denial of service, or
bypass of access controls and routing rules via specially crafted requests.

For Debian 10 buster, this problem has been fixed in version
1.8.19-1+deb10u4.

We recommend that you upgrade your haproxy packages.

For the detailed security status of haproxy please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/haproxy

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS