Debian 9948 Published by

A ruby-git security update has been released for Debian GNU/Linux 10 LTS to address a couple of vulnerabilities.



DLA 3303-1: ruby-git security update



- -----------------------------------------------------------------------
Debian LTS Advisory DLA-3303-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Utkarsh Gupta
January 31, 2023   https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package : ruby-git
Version : 1.2.8-1+deb10u1
CVE ID : CVE-2022-25648 CVE-2022-46648 CVE-2022-47318
Debian Bug : 1009926

A couple of vulnerabilities were reported against ruby-git, a Ruby
interface to the Git revision control system, that could lead to a
command injection and execution of an arbitrary ruby code by having
a user to load a repository containing a specially crafted filename
to the product.

For Debian 10 buster, these problems have been fixed in version
1.2.8-1+deb10u1.

We recommend that you upgrade your ruby-git packages.

For the detailed security status of ruby-git please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/ruby-git

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS