Debian 10033 Published by

A phpseclib security update has been released for Debian GNU/Linux 10 LTS to address a mishandling of RSA PKCS#1 v1.5 signature verification.



DLA 3197-1: phpseclib security update



- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3197-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Sylvain Beucler
November 17, 2022   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : phpseclib
Version : 1.0.19-3~deb10u1
CVE ID : CVE-2021-30130

It was discovered that phpseclib, a pure-PHP implementation of various
cryptographic and arithmetic algorithms (v1), mishandles RSA PKCS#1
v1.5 signature verification. An attacker may get invalid signatures
accepted, bypassing authorization control in specific situations.

For Debian 10 buster, this problem has been fixed in version
1.0.19-3~deb10u1.

We recommend that you upgrade your phpseclib packages.

For the detailed security status of phpseclib please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/phpseclib

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS