Debian 9902 Published by

Updated curl packages are available for both Debian GNU/Linux 11 and 12:

[DSA 5587-1] curl security update




[DSA 5587-1] curl security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5587-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
December 23, 2023 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : curl
CVE ID : CVE-2023-46218 CVE-2023-46219

Two security issues were discovered in Curl: Cookies were incorrectly
validated against the public suffix list of domains and in same cases
HSTS data could fail to save to disk.

For the oldstable distribution (bullseye), these problems have been fixed
in version 7.74.0-1.3+deb11u11.

For the stable distribution (bookworm), these problems have been fixed in
version 7.88.1-10+deb12u5.

We recommend that you upgrade your curl packages.

For the detailed security status of curl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/curl

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/