Red Hat 8831 Published by

A go-toolset:rhel8 security update has been released for Red Hat Enterprise Linux 8.



[RHSA-2023:3922-01] Critical: go-toolset:rhel8 security update


====================================================================
 Red Hat Security Advisory

Synopsis: Critical: go-toolset:rhel8 security update
Advisory ID: RHSA-2023:3922-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:3922
Issue date: 2023-06-29
CVE Names: CVE-2023-29402 CVE-2023-29403 CVE-2023-29404
CVE-2023-29405
====================================================================
1. Summary:

An update for the go-toolset:rhel8 module is now available for Red Hat
Enterprise Linux 8.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64

3. Description:

Go Toolset provides the Go programming language tools and libraries. Go is
alternatively known as golang.

Security Fix(es):

* golang: cmd/go: go command may generate unexpected code at build time
when using cgo (CVE-2023-29402)

* golang: cmd/go: go command may execute arbitrary code at build time when
using cgo (CVE-2023-29404)

* golang: cmd/cgo: Arbitratry code execution triggered by linker flags
(CVE-2023-29405)

* golang: runtime: unexpected behavior of setuid/setgid binaries
(CVE-2023-29403)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed ( https://bugzilla.redhat.com/):

2216965 - CVE-2023-29403 golang: runtime: unexpected behavior of setuid/setgid binaries
2217562 - CVE-2023-29402 golang: cmd/go: go command may generate unexpected code at build time when using cgo
2217565 - CVE-2023-29404 golang: cmd/go: go command may execute arbitrary code at build time when using cgo
2217569 - CVE-2023-29405 golang: cmd/cgo: Arbitratry code execution triggered by linker flags

6. Package List:

Red Hat Enterprise Linux AppStream (v. 8):

Source:
delve-1.9.1-1.module+el8.8.0+16778+5fbb74f5.src.rpm
go-toolset-1.19.10-1.module+el8.8.0+19203+782922b7.src.rpm
golang-1.19.10-1.module+el8.8.0+19203+782922b7.src.rpm

aarch64:
go-toolset-1.19.10-1.module+el8.8.0+19203+782922b7.aarch64.rpm
golang-1.19.10-1.module+el8.8.0+19203+782922b7.aarch64.rpm
golang-bin-1.19.10-1.module+el8.8.0+19203+782922b7.aarch64.rpm

noarch:
golang-docs-1.19.10-1.module+el8.8.0+19203+782922b7.noarch.rpm
golang-misc-1.19.10-1.module+el8.8.0+19203+782922b7.noarch.rpm
golang-src-1.19.10-1.module+el8.8.0+19203+782922b7.noarch.rpm
golang-tests-1.19.10-1.module+el8.8.0+19203+782922b7.noarch.rpm

ppc64le:
go-toolset-1.19.10-1.module+el8.8.0+19203+782922b7.ppc64le.rpm
golang-1.19.10-1.module+el8.8.0+19203+782922b7.ppc64le.rpm
golang-bin-1.19.10-1.module+el8.8.0+19203+782922b7.ppc64le.rpm

s390x:
go-toolset-1.19.10-1.module+el8.8.0+19203+782922b7.s390x.rpm
golang-1.19.10-1.module+el8.8.0+19203+782922b7.s390x.rpm
golang-bin-1.19.10-1.module+el8.8.0+19203+782922b7.s390x.rpm

x86_64:
delve-1.9.1-1.module+el8.8.0+16778+5fbb74f5.x86_64.rpm
delve-debuginfo-1.9.1-1.module+el8.8.0+16778+5fbb74f5.x86_64.rpm
delve-debugsource-1.9.1-1.module+el8.8.0+16778+5fbb74f5.x86_64.rpm
go-toolset-1.19.10-1.module+el8.8.0+19203+782922b7.x86_64.rpm
golang-1.19.10-1.module+el8.8.0+19203+782922b7.x86_64.rpm
golang-bin-1.19.10-1.module+el8.8.0+19203+782922b7.x86_64.rpm
golang-race-1.19.10-1.module+el8.8.0+19203+782922b7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-29402
https://access.redhat.com/security/cve/CVE-2023-29403
https://access.redhat.com/security/cve/CVE-2023-29404
https://access.redhat.com/security/cve/CVE-2023-29405
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is [secalert@redhat.com]. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.

--