AlmaLinux 2225 Published by

A gcc-toolset-12-binutils security update has been released for AlmaLinux 8.



ALSA-2023:2873 Moderate: gcc-toolset-12-binutils security update


Type:
security

Severity:
moderate

Release date:
2023-05-19

Description
Security Fix(es):
* binutils: NULL pointer dereference in _bfd_elf_get_symbol_version_string leads to segfault (CVE-2022-4285)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2873
CVE-2022-4285
ALSA-2023:2873

Updates packages:
gcc-toolset-12-binutils-devel-2.38-17.el8.i686.rpm
gcc-toolset-12-binutils-2.38-17.el8.x86_64.rpm
gcc-toolset-12-binutils-devel-2.38-17.el8.x86_64.rpm
gcc-toolset-12-binutils-gold-2.38-17.el8.x86_64.rpm
gcc-toolset-12-binutils-devel-2.38-17.el8.s390x.rpm
gcc-toolset-12-binutils-gold-2.38-17.el8.s390x.rpm
gcc-toolset-12-binutils-2.38-17.el8.s390x.rpm
gcc-toolset-12-binutils-2.38-17.el8.aarch64.rpm
gcc-toolset-12-binutils-devel-2.38-17.el8.aarch64.rpm
gcc-toolset-12-binutils-gold-2.38-17.el8.aarch64.rpm
gcc-toolset-12-binutils-2.38-17.el8.ppc64le.rpm
gcc-toolset-12-binutils-devel-2.38-17.el8.ppc64le.rpm
gcc-toolset-12-binutils-gold-2.38-17.el8.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2873 Moderate: gcc-toolset-12-binutils security update