AlmaLinux 2225 Published by

A container-tools:rhel8 security, bug fix, and enhancement update has been released for AlmaLinux 8.



ALSA-2023:2758 Moderate: container-tools:rhel8 security, bug fix, and enhancement update


Type:
security

Severity:
moderate

Release date:
2023-05-22

Description
Security Fix(es):
* golang: net/http: improper sanitization of Transfer-Encoding header (CVE-2022-1705)
* golang: go/parser: stack exhaustion in all Parse* functions (CVE-2022-1962)
* golang: net/http: handle server errors after sending GOAWAY (CVE-2022-27664)
* golang: encoding/xml: stack exhaustion in Decoder.Skip (CVE-2022-28131)
* golang: io/fs: stack exhaustion in Glob (CVE-2022-30630)
* golang: compress/gzip: stack exhaustion in Reader.Read (CVE-2022-30631)
* golang: path/filepath: stack exhaustion in Glob (CVE-2022-30632)
* golang: encoding/xml: stack exhaustion in Unmarshal (CVE-2022-30633)
* golang: encoding/gob: stack exhaustion in Decoder.Decode (CVE-2022-30635)
* golang: net/http/httputil: NewSingleHostReverseProxy - omit X-Forwarded-For not working (CVE-2022-32148)
* golang: net/http: excessive memory growth in a Go server accepting HTTP/2 requests (CVE-2022-41717)
* podman: symlink exchange attack in podman export volume (CVE-2023-0778)
* golang: crypto/tls: session tickets lack random ticket_age_add (CVE-2022-30629)
* golang: math/big: decoding big.Float and big.Rat types can panic if the encoded message is too short, potentially allowing a denial of service (CVE-2022-32189)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2758
CVE-2022-1705
CVE-2022-1962
CVE-2022-27664
CVE-2022-28131
CVE-2022-30629
CVE-2022-30630
CVE-2022-30631
CVE-2022-30632
CVE-2022-30633
CVE-2022-30635
CVE-2022-32148
CVE-2022-32189
CVE-2022-41717
CVE-2023-0778
ALSA-2023:2758

Updates packages:
cockpit-podman-63.1-1.module_el8.8.0+3557+7ba9cc13.noarch.rpm
podman-docker-4.4.1-8.module_el8.8.0+3568+e8578284.noarch.rpm
python3-podman-4.4.1-1.module_el8.8.0+3470+252b1910.noarch.rpm
container-selinux-2.205.0-2.module_el8.8.0+3557+7ba9cc13.noarch.rpm
udica-0.2.6-20.module_el8.8.0+3470+252b1910.noarch.rpm
containers-common-1-63.module_el8.8.0+3568+e8578284.x86_64.rpm
libslirp-4.4.0-1.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
oci-seccomp-bpf-hook-1.2.8-1.module_el8.8.0+3470+252b1910.x86_64.rpm
crit-3.15-3.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
podman-catatonit-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
podman-remote-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
criu-3.15-3.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
podman-gvproxy-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
aardvark-dns-1.5.0-2.module_el8.8.0+3470+252b1910.x86_64.rpm
criu-devel-3.15-3.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
crun-1.8.1-2.module_el8.8.0+3568+e8578284.x86_64.rpm
netavark-1.5.0-4.module_el8.8.0+3470+252b1910.x86_64.rpm
containernetworking-plugins-1.2.0-1.module_el8.8.0+3470+252b1910.x86_64.rpm
skopeo-1.11.2-0.2.module_el8.8.0+3470+252b1910.x86_64.rpm
slirp4netns-1.2.0-2.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
toolbox-tests-0.0.99.3-7.module_el8.8.0+3470+252b1910.x86_64.rpm
python3-criu-3.15-3.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
fuse-overlayfs-1.10-1.module_el8.8.0+3470+252b1910.x86_64.rpm
criu-libs-3.15-3.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
toolbox-0.0.99.3-7.module_el8.8.0+3470+252b1910.x86_64.rpm
buildah-tests-1.29.1-1.module_el8.8.0+3470+252b1910.x86_64.rpm
libslirp-devel-4.4.0-1.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
podman-plugins-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
skopeo-tests-1.11.2-0.2.module_el8.8.0+3470+252b1910.x86_64.rpm
podman-tests-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
runc-1.1.4-1.module_el8.7.0+3407+95aa0ca9.x86_64.rpm
buildah-1.29.1-1.module_el8.8.0+3470+252b1910.x86_64.rpm
conmon-2.1.6-1.module_el8.8.0+3470+252b1910.x86_64.rpm
podman-4.4.1-8.module_el8.8.0+3568+e8578284.x86_64.rpm
skopeo-tests-1.11.2-0.2.module_el8.8.0+3470+252b1910.s390x.rpm
podman-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
containers-common-1-63.module_el8.8.0+3568+e8578284.s390x.rpm
aardvark-dns-1.5.0-2.module_el8.8.0+3470+252b1910.s390x.rpm
criu-libs-3.15-3.module_el8.7.0+3407+95aa0ca9.s390x.rpm
netavark-1.5.0-4.module_el8.8.0+3470+252b1910.s390x.rpm
toolbox-0.0.99.3-7.module_el8.8.0+3470+252b1910.s390x.rpm
podman-remote-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
containernetworking-plugins-1.2.0-1.module_el8.8.0+3470+252b1910.s390x.rpm
skopeo-1.11.2-0.2.module_el8.8.0+3470+252b1910.s390x.rpm
slirp4netns-1.2.0-2.module_el8.7.0+3407+95aa0ca9.s390x.rpm
podman-catatonit-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
podman-gvproxy-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
oci-seccomp-bpf-hook-1.2.8-1.module_el8.8.0+3470+252b1910.s390x.rpm
crit-3.15-3.module_el8.7.0+3407+95aa0ca9.s390x.rpm
podman-plugins-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
buildah-tests-1.29.1-1.module_el8.8.0+3470+252b1910.s390x.rpm
crun-1.8.1-2.module_el8.8.0+3568+e8578284.s390x.rpm
criu-devel-3.15-3.module_el8.7.0+3407+95aa0ca9.s390x.rpm
toolbox-tests-0.0.99.3-7.module_el8.8.0+3470+252b1910.s390x.rpm
python3-criu-3.15-3.module_el8.7.0+3407+95aa0ca9.s390x.rpm
buildah-1.29.1-1.module_el8.8.0+3470+252b1910.s390x.rpm
runc-1.1.4-1.module_el8.7.0+3407+95aa0ca9.s390x.rpm
libslirp-4.4.0-1.module_el8.7.0+3407+95aa0ca9.s390x.rpm
conmon-2.1.6-1.module_el8.8.0+3470+252b1910.s390x.rpm
fuse-overlayfs-1.10-1.module_el8.8.0+3470+252b1910.s390x.rpm
criu-3.15-3.module_el8.7.0+3407+95aa0ca9.s390x.rpm
libslirp-devel-4.4.0-1.module_el8.7.0+3407+95aa0ca9.s390x.rpm
podman-tests-4.4.1-8.module_el8.8.0+3568+e8578284.s390x.rpm
fuse-overlayfs-1.10-1.module_el8.8.0+3470+252b1910.aarch64.rpm
criu-libs-3.15-3.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
buildah-tests-1.29.1-1.module_el8.8.0+3470+252b1910.aarch64.rpm
crun-1.8.1-2.module_el8.8.0+3568+e8578284.aarch64.rpm
skopeo-tests-1.11.2-0.2.module_el8.8.0+3470+252b1910.aarch64.rpm
skopeo-1.11.2-0.2.module_el8.8.0+3470+252b1910.aarch64.rpm
oci-seccomp-bpf-hook-1.2.8-1.module_el8.8.0+3470+252b1910.aarch64.rpm
aardvark-dns-1.5.0-2.module_el8.8.0+3470+252b1910.aarch64.rpm
podman-catatonit-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
crit-3.15-3.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
runc-1.1.4-1.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
slirp4netns-1.2.0-2.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
containers-common-1-63.module_el8.8.0+3568+e8578284.aarch64.rpm
conmon-2.1.6-1.module_el8.8.0+3470+252b1910.aarch64.rpm
toolbox-tests-0.0.99.3-7.module_el8.8.0+3470+252b1910.aarch64.rpm
python3-criu-3.15-3.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
podman-remote-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
toolbox-0.0.99.3-7.module_el8.8.0+3470+252b1910.aarch64.rpm
containernetworking-plugins-1.2.0-1.module_el8.8.0+3470+252b1910.aarch64.rpm
libslirp-4.4.0-1.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
buildah-1.29.1-1.module_el8.8.0+3470+252b1910.aarch64.rpm
podman-gvproxy-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
criu-devel-3.15-3.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
criu-3.15-3.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
podman-plugins-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
netavark-1.5.0-4.module_el8.8.0+3470+252b1910.aarch64.rpm
podman-tests-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
libslirp-devel-4.4.0-1.module_el8.7.0+3407+95aa0ca9.aarch64.rpm
podman-4.4.1-8.module_el8.8.0+3568+e8578284.aarch64.rpm
libslirp-4.4.0-1.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
netavark-1.5.0-4.module_el8.8.0+3470+252b1910.ppc64le.rpm
buildah-1.29.1-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
slirp4netns-1.2.0-2.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
podman-tests-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
toolbox-0.0.99.3-7.module_el8.8.0+3470+252b1910.ppc64le.rpm
skopeo-1.11.2-0.2.module_el8.8.0+3470+252b1910.ppc64le.rpm
skopeo-tests-1.11.2-0.2.module_el8.8.0+3470+252b1910.ppc64le.rpm
toolbox-tests-0.0.99.3-7.module_el8.8.0+3470+252b1910.ppc64le.rpm
criu-3.15-3.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
python3-criu-3.15-3.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
podman-plugins-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
podman-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
buildah-tests-1.29.1-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
containernetworking-plugins-1.2.0-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
podman-catatonit-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
crun-1.8.1-2.module_el8.8.0+3568+e8578284.ppc64le.rpm
crit-3.15-3.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
fuse-overlayfs-1.10-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
oci-seccomp-bpf-hook-1.2.8-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
criu-devel-3.15-3.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
criu-libs-3.15-3.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
podman-gvproxy-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
runc-1.1.4-1.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
podman-remote-4.4.1-8.module_el8.8.0+3568+e8578284.ppc64le.rpm
libslirp-devel-4.4.0-1.module_el8.7.0+3407+95aa0ca9.ppc64le.rpm
conmon-2.1.6-1.module_el8.8.0+3470+252b1910.ppc64le.rpm
containers-common-1-63.module_el8.8.0+3568+e8578284.ppc64le.rpm
aardvark-dns-1.5.0-2.module_el8.8.0+3470+252b1910.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2758 Moderate: container-tools:rhel8 security, bug fix, and enhancement update