AlmaLinux 2227 Published by

A libtiff security update has been released for AlmaLinux 9.



ALSA-2023:2340 Moderate: libtiff security update


Type:
security

Severity:
moderate

Release date:
2023-05-12

Description
Security Fix(es):
* libtiff: heap Buffer overflows in tiffcrop.c (CVE-2022-3570)
* libtiff: out-of-bounds write in _TIFFmemcpy in libtiff/tif_unix (CVE-2022-3597)
* libtiff: out-of-bounds write in extractContigSamplesShifted24bits in tools/tiffcrop.c (CVE-2022-3598)
* libtiff: out-of-bounds read in writeSingleSection in tools/tiffcrop.c (CVE-2022-3599)
* libtiff: out-of-bounds write in _TIFFmemset in libtiff/tif_unix.c (CVE-2022-3626)
* libtiff: out-of-bounds write in _TIFFmemcpy in libtiff/tif_unix.c (CVE-2022-3627)
* libtiff: integer overflow in function TIFFReadRGBATileExt of the file (CVE-2022-3970)
* libtiff: out-of-bounds read in tiffcp in tools/tiffcp.c (CVE-2022-4645)
* libtiff: heap buffer overflow issues related to TIFFTAG_INKNAMES and related TIFFTAG_NUMBEROFINKS value (CVE-2023-30774)
* libtiff: Heap buffer overflow in extractContigSamples32bits, tiffcrop.c (CVE-2023-30775)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2340
CVE-2022-3570
CVE-2022-3597
CVE-2022-3598
CVE-2022-3599
CVE-2022-3626
CVE-2022-3627
CVE-2022-3970
CVE-2022-4645
CVE-2023-30774
CVE-2023-30775
ALSA-2023:2340

Updates packages:
libtiff-devel-4.4.0-7.el9.i686.rpm
libtiff-4.4.0-7.el9.i686.rpm
libtiff-4.4.0-7.el9.aarch64.rpm
libtiff-devel-4.4.0-7.el9.aarch64.rpm
libtiff-4.4.0-7.el9.x86_64.rpm
libtiff-devel-4.4.0-7.el9.x86_64.rpm
libtiff-4.4.0-7.el9.ppc64le.rpm
libtiff-devel-4.4.0-7.el9.ppc64le.rpm
libtiff-4.4.0-7.el9.s390x.rpm
libtiff-devel-4.4.0-7.el9.s390x.rpm
libtiff-tools-4.4.0-7.el9.ppc64le.rpm
libtiff-tools-4.4.0-7.el9.x86_64.rpm
libtiff-tools-4.4.0-7.el9.aarch64.rpm
libtiff-tools-4.4.0-7.el9.s390x.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2340 Moderate: libtiff security update