AlmaLinux 2227 Published by

A git security and bug fix update has been released for AlmaLinux 9.



ALSA-2023:2319 Moderate: git security and bug fix update


Type:
security

Severity:
moderate

Release date:
2023-05-12

Description
Security Fix(es):
* git: On multi-user machines Git users might find themselves unexpectedly in a Git worktree (CVE-2022-24765)
* git: Bypass of safe.directory protections (CVE-2022-29187)
* git: exposure of sensitive information to a malicious actor (CVE-2022-39253)
* git: git shell function that splits command arguments can lead to arbitrary heap writes. (CVE-2022-39260)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2319
CVE-2022-24765
CVE-2022-29187
CVE-2022-39253
CVE-2022-39260
ALSA-2023:2319

Updates packages:
git-email-2.39.1-1.el9.noarch.rpm
git-all-2.39.1-1.el9.noarch.rpm
git-core-doc-2.39.1-1.el9.noarch.rpm
git-svn-2.39.1-1.el9.noarch.rpm
gitweb-2.39.1-1.el9.noarch.rpm
git-gui-2.39.1-1.el9.noarch.rpm
git-instaweb-2.39.1-1.el9.noarch.rpm
perl-Git-SVN-2.39.1-1.el9.noarch.rpm
perl-Git-2.39.1-1.el9.noarch.rpm
gitk-2.39.1-1.el9.noarch.rpm
git-core-2.39.1-1.el9.aarch64.rpm
git-credential-libsecret-2.39.1-1.el9.aarch64.rpm
git-2.39.1-1.el9.aarch64.rpm
git-daemon-2.39.1-1.el9.aarch64.rpm
git-subtree-2.39.1-1.el9.aarch64.rpm
git-daemon-2.39.1-1.el9.x86_64.rpm
git-core-2.39.1-1.el9.x86_64.rpm
git-2.39.1-1.el9.x86_64.rpm
git-subtree-2.39.1-1.el9.x86_64.rpm
git-credential-libsecret-2.39.1-1.el9.x86_64.rpm
git-credential-libsecret-2.39.1-1.el9.ppc64le.rpm
git-2.39.1-1.el9.ppc64le.rpm
git-daemon-2.39.1-1.el9.ppc64le.rpm
git-core-2.39.1-1.el9.ppc64le.rpm
git-subtree-2.39.1-1.el9.ppc64le.rpm
git-daemon-2.39.1-1.el9.s390x.rpm
git-core-2.39.1-1.el9.s390x.rpm
git-2.39.1-1.el9.s390x.rpm
git-subtree-2.39.1-1.el9.s390x.rpm
git-credential-libsecret-2.39.1-1.el9.s390x.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2319 Moderate: git security and bug fix update