AlmaLinux 2227 Published by

A tigervnc security and bug fix update has been released for AlmaLinux 9.



ALSA-2023:2257 Moderate: tigervnc security and bug fix update


Type:
security

Severity:
moderate

Release date:
2023-05-12

Description
Security Fix(es):
* xorg-x11-server: XkbGetKbdByName use-after-free (CVE-2022-4283)
* xorg-x11-server: XTestSwapFakeInput stack overflow (CVE-2022-46340)
* xorg-x11-server: XIPassiveUngrab out-of-bounds access (CVE-2022-46341)
* xorg-x11-server: XvdiSelectVideoNotify use-after-free (CVE-2022-46342)
* xorg-x11-server: ScreenSaverSetAttributes use-after-free (CVE-2022-46343)
* xorg-x11-server: XIChangeProperty out-of-bounds access (CVE-2022-46344)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2257
CVE-2022-4283
CVE-2022-46340
CVE-2022-46341
CVE-2022-46342
CVE-2022-46343
CVE-2022-46344
ALSA-2023:2257

Updates packages:
tigervnc-icons-1.12.0-13.el9_2.noarch.rpm
tigervnc-license-1.12.0-13.el9_2.noarch.rpm
tigervnc-selinux-1.12.0-13.el9_2.noarch.rpm
tigervnc-server-1.12.0-13.el9_2.aarch64.rpm
tigervnc-1.12.0-13.el9_2.aarch64.rpm
tigervnc-server-minimal-1.12.0-13.el9_2.aarch64.rpm
tigervnc-server-module-1.12.0-13.el9_2.aarch64.rpm
tigervnc-server-module-1.12.0-13.el9_2.x86_64.rpm
tigervnc-1.12.0-13.el9_2.x86_64.rpm
tigervnc-server-1.12.0-13.el9_2.x86_64.rpm
tigervnc-server-minimal-1.12.0-13.el9_2.x86_64.rpm
tigervnc-server-minimal-1.12.0-13.el9_2.ppc64le.rpm
tigervnc-server-1.12.0-13.el9_2.ppc64le.rpm
tigervnc-1.12.0-13.el9_2.ppc64le.rpm
tigervnc-server-module-1.12.0-13.el9_2.ppc64le.rpm
tigervnc-server-minimal-1.12.0-13.el9_2.s390x.rpm
tigervnc-server-module-1.12.0-13.el9_2.s390x.rpm
tigervnc-1.12.0-13.el9_2.s390x.rpm
tigervnc-server-1.12.0-13.el9_2.s390x.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2257 Moderate: tigervnc security and bug fix update