AlmaLinux 2226 Published by

A libguestfs-winsupport security update has been released for AlmaLinux 9.



ALSA-2023:2179 Moderate: libguestfs-winsupport security update


Type:
security

Severity:
moderate

Release date:
2023-05-12

Description
Security Fix(es):
* ntfs-3g: heap-based buffer overflow in ntfsck (CVE-2021-46790)
* ntfs-3g: crafted NTFS image can cause heap exhaustion in ntfs_get_attribute_value (CVE-2022-30784)
* ntfs-3g: crafted NTFS image can cause a heap-based buffer overflow in ntfs_names_full_collate (CVE-2022-30786)
* ntfs-3g: crafted NTFS image can cause a heap-based buffer overflow in ntfs_mft_rec_alloc (CVE-2022-30788)
* ntfs-3g: crafted NTFS image can cause a heap-based buffer overflow in ntfs_check_log_client_array (CVE-2022-30789)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2179
CVE-2021-46790
CVE-2022-30784
CVE-2022-30786
CVE-2022-30788
CVE-2022-30789
ALSA-2023:2179

Updates packages:
libguestfs-winsupport-9.2-1.el9.aarch64.rpm
libguestfs-winsupport-9.2-1.el9.x86_64.rpm
libguestfs-winsupport-9.2-1.el9.s390x.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2179 Moderate: libguestfs-winsupport security update