AlmaLinux 2225 Published by

A postgresql:13 security update has been released for AlmaLinux 8.



ALSA-2023:1576 Moderate: postgresql:13 security update


Type:
security

Severity:
moderate

Release date:
2023-04-05

Description
Security Fix(es):
* postgresql: Extension scripts replace objects not belonging to the extension. (CVE-2022-2625)
* postgresql: Client memory disclosure when connecting with Kerberos to modified server (CVE-2022-41862)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
RHSA-2023:1576
CVE-2022-2625
CVE-2022-41862
ALSA-2023:1576

Updates packages:
postgresql-test-rpm-macros-13.10-1.module_el8.7.0+3498+cb1ef3c6.noarch.rpm
postgresql-test-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
pg_repack-1.4.6-3.module_el8.6.0+2760+1746ec94.aarch64.rpm
postgresql-server-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-server-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-plperl-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
pgaudit-1.5.0-1.module_el8.6.0+2760+1746ec94.aarch64.rpm
postgresql-docs-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-static-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-upgrade-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgres-decoderbufs-0.10.0-2.module_el8.6.0+2760+1746ec94.aarch64.rpm
postgresql-upgrade-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-contrib-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-pltcl-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-plpython3-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-13.10-1.module_el8.7.0+3498+cb1ef3c6.aarch64.rpm
postgresql-static-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-plperl-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-plpython3-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-upgrade-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-upgrade-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-server-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgres-decoderbufs-0.10.0-2.module_el8.6.0+2760+1746ec94.x86_64.rpm
postgresql-test-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
pg_repack-1.4.6-3.module_el8.6.0+2760+1746ec94.x86_64.rpm
postgresql-pltcl-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-docs-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-server-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
pgaudit-1.5.0-1.module_el8.6.0+2760+1746ec94.x86_64.rpm
postgresql-contrib-13.10-1.module_el8.7.0+3498+cb1ef3c6.x86_64.rpm
postgresql-docs-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-upgrade-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-static-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-plperl-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-plpython3-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-server-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-test-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-upgrade-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
pgaudit-1.5.0-1.module_el8.6.0+3095+ee60d910.s390x.rpm
postgres-decoderbufs-0.10.0-2.module_el8.6.0+3095+ee60d910.s390x.rpm
pg_repack-1.4.6-3.module_el8.6.0+3095+ee60d910.s390x.rpm
postgresql-contrib-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-pltcl-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgresql-server-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.s390x.rpm
postgres-decoderbufs-0.10.0-2.module_el8.6.0+2760+1746ec94.ppc64le.rpm
postgresql-plpython3-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-contrib-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-upgrade-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-server-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-test-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
pgaudit-1.5.0-1.module_el8.6.0+2760+1746ec94.ppc64le.rpm
postgresql-upgrade-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-static-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-pltcl-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
pg_repack-1.4.6-3.module_el8.6.0+2760+1746ec94.ppc64le.rpm
postgresql-server-devel-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-plperl-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm
postgresql-docs-13.10-1.module_el8.7.0+3498+cb1ef3c6.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:1576 Moderate: postgresql:13 security update