AlmaLinux 2225 Published by

A kernel security and bug fix update has been released for AlmaLinux 9.



ALSA-2023:0951 Important: kernel security and bug fix update


Type:
security

Severity:
important

Release date:
2023-02-28

Description
Security Fix(es):
* kernel: use-after-free caused by l2cap_reassemble_sdu() in net/bluetooth/l2cap_core.c (CVE-2022-3564)
* kernel: stack overflow in do_proc_dointvec and proc_skip_spaces (CVE-2022-4378)
* kernel: use-after-free in __nfs42_ssc_open() in fs/nfs/nfs4file.c leading to remote Denial of Service attack (CVE-2022-4379)
* kernel: Netfilter integer overflow vulnerability in nft_payload_copy_vlan (CVE-2023-0179)
* kernel: an out-of-bounds vulnerability in i2c-ismt driver (CVE-2022-2873)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Bug Fix(es):
* AlmaLinux 9.0: LTP Test failure and crash at fork14 on Sapphire Rapids Platinum 8280+ (BZ#2133083)
* AlmaLinux 9.1 Extending NMI watchdog's timer during LPM (BZ#2140085)
* AMDSERVER 9.1: amdpstate driver incorrectly designed to load as default for Genoa (BZ#2151274)
* qla2xxx NVMe-FC: WARNING: CPU: 0 PID: 124072 at drivers/scsi/qla2xxx/qla_init.c:70 qla2xxx_rel_done_warning+0x25/0x30 qla2xxx (BZ#2152178)
* Regression: Kernel panic on Lenovo T480 with AH40 USB-C docking station (BZ#2153277)
* Scheduler Update (rhel9.2) (BZ#2153792)
* AlmaLinux9.1, Nx_Gzip: nr_total_credits is not decremented when processing units are reduced by dlpar in shared mode. (FW1030 / DLPAR) (BZ#2154305)
* MSFT, MANA, NET Patch AlmaLinux-9: Fix race on per-CQ variable napi_iperf panic fix (BZ#2155145)
* Azure vPCI AlmaLinux-9 add the support of multi-MSI (BZ#2155459)
* Azure AlmaLinux-9: VM Deployment Failures Patch Request (BZ#2155930)
* The 'date' command shows wrong time in nested KVM s390x guest (BZ#2158815)
* AlmaLinux-9.2: Update NVMe driver to sync with upstream v6.0 (BZ#2161344)
* CEE cephfs: AlmaLinux9 cephfs client crashing with RIP: 0010:netfs_rreq_unlock+0xef/0x380 netfs (BZ#2161418)
* block layer: update with upstream v6.0 (BZ#2162535)

References:
RHSA-2023:0951
CVE-2022-2873
CVE-2022-3564
CVE-2022-4378
CVE-2022-4379
CVE-2023-0179
ALSA-2023:0951

Updates packages:
kernel-doc-5.14.0-162.18.1.el9_1.noarch.rpm
kernel-debug-devel-matched-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-devel-matched-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-devel-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-debug-devel-5.14.0-162.18.1.el9_1.aarch64.rpm
perf-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-zfcpdump-devel-5.14.0-162.18.1.el9_1.s390x.rpm
perf-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-zfcpdump-devel-matched-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-devel-matched-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-devel-matched-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-devel-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-devel-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-devel-matched-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-devel-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-debug-devel-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-devel-matched-5.14.0-162.18.1.el9_1.ppc64le.rpm
perf-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-abi-stablelists-5.14.0-162.18.1.el9_1.noarch.rpm
kernel-debug-devel-5.14.0-162.18.1.el9_1.x86_64.rpm
perf-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-devel-matched-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-devel-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-devel-matched-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-core-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-modules-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-debug-core-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-tools-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-debug-modules-extra-5.14.0-162.18.1.el9_1.ppc64le.rpm
bpftool-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-debug-modules-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-modules-extra-5.14.0-162.18.1.el9_1.ppc64le.rpm
python3-perf-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-tools-libs-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-tools-libs-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-tools-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-modules-extra-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-core-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-modules-5.14.0-162.18.1.el9_1.x86_64.rpm
bpftool-5.14.0-162.18.1.el9_1.x86_64.rpm
python3-perf-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-core-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-modules-extra-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-debug-modules-5.14.0-162.18.1.el9_1.x86_64.rpm
python3-perf-5.14.0-162.18.1.el9_1.aarch64.rpm
bpftool-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-tools-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-debug-modules-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-debug-modules-extra-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-debug-core-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-modules-extra-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-tools-libs-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-debug-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-modules-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-core-5.14.0-162.18.1.el9_1.aarch64.rpm
bpftool-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-modules-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-tools-5.14.0-162.18.1.el9_1.s390x.rpm
python3-perf-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-zfcpdump-modules-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-core-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-core-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-zfcpdump-core-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-modules-extra-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-debug-modules-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-modules-extra-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-zfcpdump-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-zfcpdump-modules-extra-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-cross-headers-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-tools-libs-devel-5.14.0-162.18.1.el9_1.ppc64le.rpm
kernel-cross-headers-5.14.0-162.18.1.el9_1.s390x.rpm
kernel-tools-libs-devel-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-cross-headers-5.14.0-162.18.1.el9_1.x86_64.rpm
kernel-cross-headers-5.14.0-162.18.1.el9_1.aarch64.rpm
kernel-tools-libs-devel-5.14.0-162.18.1.el9_1.aarch64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:0951 Important: kernel security and bug fix update