AlmaLinux 2260 Published by

A xorg-x11-server-Xwayland security update has been released for AlmaLinux 9.



ALSA-2022:8222 Moderate: xorg-x11-server-Xwayland security update


Type:
security

Severity:
moderate

Release date:
2022-11-18

Description
Security Fix(es):
* xorg-x11-server: X.Org Server ProcXkbSetGeometry out-of-bounds access (CVE-2022-2319)
* xorg-x11-server: out-of-bounds access in ProcXkbSetDeviceInfo request handler of the Xkb extension (CVE-2022-2320)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2022:8222
CVE-2022-2319
CVE-2022-2320
ALSA-2022:8222

Updates packages:
xorg-x11-server-Xwayland-21.1.3-3.el9.x86_64.rpm
xorg-x11-server-Xwayland-21.1.3-3.el9.ppc64le.rpm
xorg-x11-server-Xwayland-21.1.3-3.el9.s390x.rpm
xorg-x11-server-Xwayland-21.1.3-3.el9.aarch64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:8222 Moderate: xorg-x11-server-Xwayland security update