AlmaLinux 2260 Published by

A libtiff security update has been released for AlmaLinux 9.



ALSA-2022:8194 Moderate: libtiff security update


Type:
security

Severity:
moderate

Release date:
2022-11-18

Description
Security Fix(es):
* libtiff: Denial of Service via crafted TIFF file (CVE-2022-0561)
* libtiff: Null source pointer lead to Denial of Service via crafted TIFF file (CVE-2022-0562)
* libtiff: reachable assertion (CVE-2022-0865)
* libtiff: Out-of-bounds Read error in tiffcp (CVE-2022-0924)
* libtiff: stack-buffer-overflow in tiffcp.c in main() (CVE-2022-1355)
* libtiff: out-of-bounds read in _TIFFmemcpy() in tif_unix.c (CVE-2022-22844)
* libtiff: heap buffer overflow in extractImageSection (CVE-2022-0891)
* tiff: Null source pointer passed as an argument to memcpy in TIFFFetchNormalTag() in tif_dirread.c (CVE-2022-0908)
* tiff: Divide By Zero error in tiffcrop (CVE-2022-0909)
* libtiff: heap-buffer-overflow in TIFFReadRawDataStriped() in tiffinfo.c (CVE-2022-1354)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2022:8194
CVE-2022-0561
CVE-2022-0562
CVE-2022-0865
CVE-2022-0891
CVE-2022-0908
CVE-2022-0909
CVE-2022-0924
CVE-2022-1354
CVE-2022-1355
CVE-2022-22844
ALSA-2022:8194

Updates packages:
libtiff-4.4.0-2.el9.i686.rpm
libtiff-devel-4.4.0-2.el9.i686.rpm
libtiff-devel-4.4.0-2.el9.x86_64.rpm
libtiff-4.4.0-2.el9.x86_64.rpm
libtiff-devel-4.4.0-2.el9.ppc64le.rpm
libtiff-4.4.0-2.el9.ppc64le.rpm
libtiff-devel-4.4.0-2.el9.s390x.rpm
libtiff-4.4.0-2.el9.s390x.rpm
libtiff-devel-4.4.0-2.el9.aarch64.rpm
libtiff-4.4.0-2.el9.aarch64.rpm
libtiff-tools-4.4.0-2.el9.x86_64.rpm
libtiff-tools-4.4.0-2.el9.s390x.rpm
libtiff-tools-4.4.0-2.el9.aarch64.rpm
libtiff-tools-4.4.0-2.el9.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:8194 Moderate: libtiff security update