AlmaLinux 2260 Published by

A grafana-pcp security update has been released for AlmaLinux 8.



ALSA-2022:7648 Moderate: grafana-pcp security update


Type:
security

Severity:
moderate

Release date:
2022-11-11

Description
Security Fix(es):
* golang: net/http: improper sanitization of Transfer-Encoding header (CVE-2022-1705)
* golang: io/fs: stack exhaustion in Glob (CVE-2022-30630)
* golang: compress/gzip: stack exhaustion in Reader.Read (CVE-2022-30631)
* golang: path/filepath: stack exhaustion in Glob (CVE-2022-30632)
* golang: encoding/gob: stack exhaustion in Decoder.Decode (CVE-2022-30635)
* golang: net/http/httputil: NewSingleHostReverseProxy - omit X-Forwarded-For not working (CVE-2022-32148)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2022:7648
CVE-2022-1705
CVE-2022-30630
CVE-2022-30631
CVE-2022-30632
CVE-2022-30635
CVE-2022-32148
ALSA-2022:7648

Updates packages:
grafana-pcp-3.2.0-2.el8.aarch64.rpm
grafana-pcp-3.2.0-2.el8.s390x.rpm
grafana-pcp-3.2.0-2.el8.x86_64.rpm
grafana-pcp-3.2.0-2.el8.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:7648 Moderate: grafana-pcp security update