AlmaLinux 2263 Published by

A httpd:2.4 security update has been released for AlmaLinux 8.



ALSA-2022:7647 Moderate: httpd:2.4 security update


Type:
security

Severity:
moderate

Release date:
2022-11-11

Description
Security Fix(es):
* httpd: mod_sed: Read/write beyond bounds (CVE-2022-23943)
* httpd: mod_lua: Use of uninitialized value of in r:parsebody (CVE-2022-22719)
* httpd: core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody (CVE-2022-22721)
* httpd: mod_proxy_ajp: Possible request smuggling (CVE-2022-26377)
* httpd: mod_lua: DoS in r:parsebody (CVE-2022-29404)
* httpd: mod_sed: DoS vulnerability (CVE-2022-30522)
* httpd: mod_proxy: X-Forwarded-For dropped by hop-by-hop mechanism (CVE-2022-31813)
* httpd: Out-of-bounds read via ap_rwrite() (CVE-2022-28614)
* httpd: Out-of-bounds read in ap_strcmp_match() (CVE-2022-28615)
* httpd: mod_lua: Information disclosure with websockets (CVE-2022-30556)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2022:7647
CVE-2022-22719
CVE-2022-22721
CVE-2022-23943
CVE-2022-26377
CVE-2022-28614
CVE-2022-28615
CVE-2022-29404
CVE-2022-30522
CVE-2022-30556
CVE-2022-31813
ALSA-2022:7647

Updates packages:
httpd-manual-2.4.37-51.module_el8.7.0+3281+01e58653.noarch.rpm
httpd-filesystem-2.4.37-51.module_el8.7.0+3281+01e58653.noarch.rpm
mod_ldap-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
httpd-devel-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
mod_md-2.0.8-8.module_el8.6.0+2872+fe0ff7aa.aarch64.rpm
mod_ssl-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
httpd-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
mod_http2-1.15.7-5.module_el8.6.0+2872+fe0ff7aa.aarch64.rpm
httpd-tools-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
mod_session-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
mod_proxy_html-2.4.37-51.module_el8.7.0+3281+01e58653.aarch64.rpm
mod_proxy_html-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
httpd-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
mod_ldap-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
httpd-devel-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
httpd-tools-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
mod_ssl-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
mod_session-2.4.37-51.module_el8.7.0+3281+01e58653.s390x.rpm
mod_md-2.0.8-8.module_el8.6.0+3031+fb177b09.s390x.rpm
mod_http2-1.15.7-5.module_el8.6.0+3031+fb177b09.s390x.rpm
mod_md-2.0.8-8.module_el8.6.0+2872+fe0ff7aa.x86_64.rpm
mod_http2-1.15.7-5.module_el8.6.0+2872+fe0ff7aa.x86_64.rpm
mod_ssl-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
mod_proxy_html-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
httpd-tools-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
mod_session-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
mod_ldap-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
httpd-devel-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
httpd-2.4.37-51.module_el8.7.0+3281+01e58653.x86_64.rpm
mod_ldap-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
mod_ssl-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
mod_md-2.0.8-8.module_el8.6.0+2872+fe0ff7aa.ppc64le.rpm
httpd-devel-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
mod_http2-1.15.7-5.module_el8.6.0+2872+fe0ff7aa.ppc64le.rpm
httpd-tools-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
mod_proxy_html-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
mod_session-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm
httpd-2.4.37-51.module_el8.7.0+3281+01e58653.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:7647 Moderate: httpd:2.4 security update