AlmaLinux 2263 Published by

A container-tools:4.0 security and bug fix update has been released for AlmaLinux 8.



ALSA-2022:7469 Moderate: container-tools:4.0 security and bug fix update


Type:
security

Severity:
moderate

Release date:
2022-11-14

Description
Security Fix(es):
* cri-o: memory exhaustion on the node when access to the kube api (CVE-2022-1708)
* golang: crash in a golang.org/x/crypto/ssh server (CVE-2022-27191)
* runc: incorrect handling of inheritable capabilities (CVE-2022-29162)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2022:7469
CVE-2022-1708
CVE-2022-27191
CVE-2022-29162
ALSA-2022:7469

Updates packages:
udica-0.2.6-3.module_el8.7.0+3344+484dae7b.noarch.rpm
python3-podman-4.0.0-1.module_el8.6.0+2877+8e437bf5.noarch.rpm
cockpit-podman-46-1.module_el8.7.0+3344+5bcd850f.noarch.rpm
container-selinux-2.189.0-1.module_el8.7.0+3344+5bcd850f.noarch.rpm
buildah-tests-1.24.5-2.module_el8.7.0+3344+5bcd850f.aarch64.rpm
aardvark-dns-1.0.1-35.module_el8.7.0+3344+5bcd850f.aarch64.rpm
podman-remote-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
skopeo-1.6.2-5.module_el8.7.0+3344+5bcd850f.aarch64.rpm
netavark-1.0.1-35.module_el8.7.0+3344+5bcd850f.aarch64.rpm
podman-tests-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
criu-devel-3.15-3.module_el8.6.0+2877+8e437bf5.aarch64.rpm
conmon-2.1.4-1.module_el8.7.0+3344+5bcd850f.aarch64.rpm
libslirp-4.4.0-1.module_el8.6.0+2877+8e437bf5.aarch64.rpm
containernetworking-plugins-1.1.1-2.module_el8.7.0+3344+5bcd850f.aarch64.rpm
podman-catatonit-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
podman-docker-4.0.2-8.module_el8.7.0+3344+5bcd850f.noarch.rpm
podman-gvproxy-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
oci-seccomp-bpf-hook-1.2.5-1.module_el8.7.0+3344+5bcd850f.aarch64.rpm
toolbox-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.aarch64.rpm
runc-1.1.4-1.module_el8.7.0+3344+484dae7b.aarch64.rpm
buildah-1.24.5-2.module_el8.7.0+3344+5bcd850f.aarch64.rpm
fuse-overlayfs-1.9-1.module_el8.7.0+3344+5bcd850f.aarch64.rpm
toolbox-tests-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.aarch64.rpm
libslirp-devel-4.4.0-1.module_el8.6.0+2877+8e437bf5.aarch64.rpm
podman-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
podman-plugins-4.0.2-8.module_el8.7.0+3344+5bcd850f.aarch64.rpm
slirp4netns-1.1.8-2.module_el8.6.0+2877+8e437bf5.aarch64.rpm
criu-3.15-3.module_el8.6.0+2877+8e437bf5.aarch64.rpm
containers-common-1-35.module_el8.7.0+3344+5bcd850f.aarch64.rpm
crun-1.5-1.module_el8.7.0+3344+5bcd850f.aarch64.rpm
skopeo-tests-1.6.2-5.module_el8.7.0+3344+5bcd850f.aarch64.rpm
criu-libs-3.15-3.module_el8.6.0+2877+8e437bf5.aarch64.rpm
crit-3.15-3.module_el8.6.0+2877+8e437bf5.aarch64.rpm
python3-criu-3.15-3.module_el8.6.0+2877+8e437bf5.aarch64.rpm
podman-catatonit-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
crun-1.5-1.module_el8.7.0+3344+5bcd850f.x86_64.rpm
fuse-overlayfs-1.9-1.module_el8.7.0+3344+5bcd850f.x86_64.rpm
aardvark-dns-1.0.1-35.module_el8.7.0+3344+5bcd850f.x86_64.rpm
skopeo-tests-1.6.2-5.module_el8.7.0+3344+5bcd850f.x86_64.rpm
libslirp-devel-4.4.0-1.module_el8.6.0+2877+8e437bf5.x86_64.rpm
podman-tests-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
podman-plugins-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
podman-gvproxy-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
skopeo-1.6.2-5.module_el8.7.0+3344+5bcd850f.x86_64.rpm
netavark-1.0.1-35.module_el8.7.0+3344+5bcd850f.x86_64.rpm
podman-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
criu-devel-3.15-3.module_el8.6.0+2877+8e437bf5.x86_64.rpm
slirp4netns-1.1.8-2.module_el8.6.0+2877+8e437bf5.x86_64.rpm
crit-3.15-3.module_el8.6.0+2877+8e437bf5.x86_64.rpm
conmon-2.1.4-1.module_el8.7.0+3344+5bcd850f.x86_64.rpm
oci-seccomp-bpf-hook-1.2.5-1.module_el8.7.0+3344+5bcd850f.x86_64.rpm
buildah-tests-1.24.5-2.module_el8.7.0+3344+5bcd850f.x86_64.rpm
toolbox-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.x86_64.rpm
criu-libs-3.15-3.module_el8.6.0+2877+8e437bf5.x86_64.rpm
podman-remote-4.0.2-8.module_el8.7.0+3344+5bcd850f.x86_64.rpm
runc-1.1.4-1.module_el8.7.0+3344+484dae7b.x86_64.rpm
containers-common-1-35.module_el8.7.0+3344+5bcd850f.x86_64.rpm
toolbox-tests-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.x86_64.rpm
containernetworking-plugins-1.1.1-2.module_el8.7.0+3344+5bcd850f.x86_64.rpm
criu-3.15-3.module_el8.6.0+2877+8e437bf5.x86_64.rpm
python3-criu-3.15-3.module_el8.6.0+2877+8e437bf5.x86_64.rpm
buildah-1.24.5-2.module_el8.7.0+3344+5bcd850f.x86_64.rpm
libslirp-4.4.0-1.module_el8.6.0+2877+8e437bf5.x86_64.rpm
containers-common-1-35.module_el8.7.0+3344+5bcd850f.s390x.rpm
podman-plugins-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
netavark-1.0.1-35.module_el8.7.0+3344+5bcd850f.s390x.rpm
libslirp-devel-4.4.0-1.module_el8.6.0+3137+d33c3efb.s390x.rpm
fuse-overlayfs-1.9-1.module_el8.7.0+3344+5bcd850f.s390x.rpm
oci-seccomp-bpf-hook-1.2.5-1.module_el8.7.0+3344+5bcd850f.s390x.rpm
criu-devel-3.15-3.module_el8.6.0+3137+d33c3efb.s390x.rpm
buildah-1.24.5-2.module_el8.7.0+3344+5bcd850f.s390x.rpm
podman-tests-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
conmon-2.1.4-1.module_el8.7.0+3344+5bcd850f.s390x.rpm
runc-1.1.4-1.module_el8.7.0+3344+484dae7b.s390x.rpm
aardvark-dns-1.0.1-35.module_el8.7.0+3344+5bcd850f.s390x.rpm
crit-3.15-3.module_el8.6.0+3137+d33c3efb.s390x.rpm
python3-criu-3.15-3.module_el8.6.0+3137+d33c3efb.s390x.rpm
slirp4netns-1.1.8-2.module_el8.6.0+3137+d33c3efb.s390x.rpm
crun-1.5-1.module_el8.7.0+3344+5bcd850f.s390x.rpm
toolbox-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.s390x.rpm
buildah-tests-1.24.5-2.module_el8.7.0+3344+5bcd850f.s390x.rpm
podman-remote-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
skopeo-1.6.2-5.module_el8.7.0+3344+5bcd850f.s390x.rpm
containernetworking-plugins-1.1.1-2.module_el8.7.0+3344+5bcd850f.s390x.rpm
criu-3.15-3.module_el8.6.0+3137+d33c3efb.s390x.rpm
podman-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
skopeo-tests-1.6.2-5.module_el8.7.0+3344+5bcd850f.s390x.rpm
criu-libs-3.15-3.module_el8.6.0+3137+d33c3efb.s390x.rpm
podman-gvproxy-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
libslirp-4.4.0-1.module_el8.6.0+3137+d33c3efb.s390x.rpm
podman-catatonit-4.0.2-8.module_el8.7.0+3344+5bcd850f.s390x.rpm
toolbox-tests-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.s390x.rpm
podman-gvproxy-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
fuse-overlayfs-1.9-1.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
oci-seccomp-bpf-hook-1.2.5-1.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
toolbox-tests-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
libslirp-4.4.0-1.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
aardvark-dns-1.0.1-35.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
criu-3.15-3.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
skopeo-1.6.2-5.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
slirp4netns-1.1.8-2.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
podman-tests-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
criu-devel-3.15-3.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
podman-remote-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
podman-plugins-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
python3-criu-3.15-3.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
libslirp-devel-4.4.0-1.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
criu-libs-3.15-3.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
containers-common-1-35.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
crit-3.15-3.module_el8.6.0+2877+8e437bf5.ppc64le.rpm
containernetworking-plugins-1.1.1-2.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
skopeo-tests-1.6.2-5.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
podman-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
netavark-1.0.1-35.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
buildah-tests-1.24.5-2.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
runc-1.1.4-1.module_el8.7.0+3344+484dae7b.ppc64le.rpm
toolbox-0.0.99.3-0.5.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
crun-1.5-1.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
podman-catatonit-4.0.2-8.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
buildah-1.24.5-2.module_el8.7.0+3344+5bcd850f.ppc64le.rpm
conmon-2.1.4-1.module_el8.7.0+3344+5bcd850f.ppc64le.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:7469 Moderate: container-tools:4.0 security and bug fix update