AlmaLinux 2260 Published by

A nodejs security update has been released for AlmaLinux 9.



ALSA-2022:6963 Important: nodejs security update


Type:
security

Severity:
important

Release date:
2022-10-19

Description
The following packages have been upgraded to a later upstream version: nodejs (16.17.1).
Security Fix(es):
* nodejs: weak randomness in WebCrypto keygen (CVE-2022-35255)
* nodejs: HTTP Request Smuggling due to incorrect parsing of header fields (CVE-2022-35256)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
RHSA-2022:6963
CVE-2022-35255
CVE-2022-35256
ALSA-2022:6963

Updates packages:
nodejs-docs-16.17.1-1.el9_0.noarch.rpm
nodejs-libs-16.17.1-1.el9_0.i686.rpm
nodejs-full-i18n-16.17.1-1.el9_0.x86_64.rpm
nodejs-16.17.1-1.el9_0.x86_64.rpm
npm-8.15.0-1.16.17.1.1.el9_0.x86_64.rpm
nodejs-16.17.1-1.el9_0.ppc64le.rpm
npm-8.15.0-1.16.17.1.1.el9_0.ppc64le.rpm
nodejs-full-i18n-16.17.1-1.el9_0.ppc64le.rpm
nodejs-libs-16.17.1-1.el9_0.ppc64le.rpm
npm-8.15.0-1.16.17.1.1.el9_0.aarch64.rpm
nodejs-full-i18n-16.17.1-1.el9_0.aarch64.rpm
nodejs-libs-16.17.1-1.el9_0.aarch64.rpm
nodejs-16.17.1-1.el9_0.aarch64.rpm
npm-8.15.0-1.16.17.1.1.el9_0.s390x.rpm
nodejs-16.17.1-1.el9_0.s390x.rpm
nodejs-libs-16.17.1-1.el9_0.s390x.rpm
nodejs-full-i18n-16.17.1-1.el9_0.s390x.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:6963 Important: nodejs security update