AlmaLinux 2260 Published by

A ruby security, bug fix, and enhancement update has been released for AlmaLinux 9.



ALSA-2022:6585 Moderate: ruby security, bug fix, and enhancement update


Type:
security

Severity:
moderate

Release date:
2022-10-19

Description
The following packages have been upgraded to a later upstream version: ruby (3.0.4). (BZ#2109428)
Security Fix(es):
* Ruby: Double free in Regexp compilation (CVE-2022-28738)
* Ruby: Buffer overrun in String-to-Float conversion (CVE-2022-28739)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
RHSA-2022:6585
CVE-2022-28738
CVE-2022-28739
ALSA-2022:6585

Updates packages:
rubygem-typeprof-0.15.2-160.el9_0.noarch.rpm
rubygems-devel-3.2.33-160.el9_0.noarch.rpm
rubygem-rexml-3.2.5-160.el9_0.noarch.rpm
ruby-libs-3.0.4-160.el9_0.i686.rpm
rubygem-rss-0.2.9-160.el9_0.noarch.rpm
ruby-3.0.4-160.el9_0.i686.rpm
rubygem-test-unit-3.3.7-160.el9_0.noarch.rpm
rubygem-power_assert-1.2.0-160.el9_0.noarch.rpm
rubygems-3.2.33-160.el9_0.noarch.rpm
rubygem-rbs-1.4.0-160.el9_0.noarch.rpm
rubygem-irb-1.3.5-160.el9_0.noarch.rpm
rubygem-bundler-2.2.33-160.el9_0.noarch.rpm
ruby-default-gems-3.0.4-160.el9_0.noarch.rpm
rubygem-rake-13.0.3-160.el9_0.noarch.rpm
rubygem-minitest-5.14.2-160.el9_0.noarch.rpm
rubygem-rdoc-6.3.3-160.el9_0.noarch.rpm
ruby-devel-3.0.4-160.el9_0.i686.rpm
rubygem-bigdecimal-3.0.0-160.el9_0.x86_64.rpm
rubygem-json-2.5.1-160.el9_0.x86_64.rpm
rubygem-io-console-0.5.7-160.el9_0.x86_64.rpm
rubygem-psych-3.3.2-160.el9_0.x86_64.rpm
rubygem-bigdecimal-3.0.0-160.el9_0.ppc64le.rpm
rubygem-psych-3.3.2-160.el9_0.ppc64le.rpm
ruby-3.0.4-160.el9_0.ppc64le.rpm
rubygem-json-2.5.1-160.el9_0.ppc64le.rpm
rubygem-io-console-0.5.7-160.el9_0.ppc64le.rpm
ruby-devel-3.0.4-160.el9_0.ppc64le.rpm
ruby-libs-3.0.4-160.el9_0.ppc64le.rpm
rubygem-bigdecimal-3.0.0-160.el9_0.aarch64.rpm
rubygem-io-console-0.5.7-160.el9_0.aarch64.rpm
ruby-libs-3.0.4-160.el9_0.aarch64.rpm
ruby-devel-3.0.4-160.el9_0.aarch64.rpm
rubygem-psych-3.3.2-160.el9_0.aarch64.rpm
ruby-3.0.4-160.el9_0.aarch64.rpm
rubygem-json-2.5.1-160.el9_0.aarch64.rpm
rubygem-bigdecimal-3.0.0-160.el9_0.s390x.rpm
ruby-devel-3.0.4-160.el9_0.s390x.rpm
ruby-libs-3.0.4-160.el9_0.s390x.rpm
rubygem-io-console-0.5.7-160.el9_0.s390x.rpm
rubygem-psych-3.3.2-160.el9_0.s390x.rpm
rubygem-json-2.5.1-160.el9_0.s390x.rpm
ruby-3.0.4-160.el9_0.s390x.rpm
ruby-doc-3.0.4-160.el9_0.noarch.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2022:6585 Moderate: ruby security, bug fix, and enhancement update