More weird dual boot stuff..

I have been reading through the posts here about dual boots in an effort to sort this out and figured a post was needed - help please! Long post I know, forgive me, but I figured the details would help! I have an Asus P5GD1 m/b based system with two CD drives on primary IDE and two hd - 160GB SATA, and a 80GB PATA ...

Everything Linux 1798 This topic was started by ,



data/avatar/default/avatar30.webp

4 Posts
Location -
Joined 2006-06-27
I have been reading through the posts here about dual boots in an effort to sort this out and figured a post was needed - help please! Long post I know, forgive me, but I figured the details would help!
 
I have an Asus P5GD1 m/b based system with two CD drives on primary IDE and two hd - 160GB SATA, and a 80GB PATA connected to a hardware RAID capable IDE port (ITE8212 RAID) just as a simple disk, not RAID, seen as tertiary master, or drive 5 (there is no secondary IDE channel socket on the MB).
 
The BIOS is set to boot order of floppy / CD / hard drive, and separately the hard drive boot order is set to SATA first, PATA second.
 
The SATA has XP installed, full 160GB.
 
 
OK - install FC5. Get to disk information. Reads two drives - /dev/hde for the PATA, /dev/sda for the SATA, as I expected. Set up standard Linux partitions on the PATA, and it wants to install the Grub to the MBR of /dev/hde. Change that to be MBR on /dev/sda (as the first booting drive), install, reboot, and XP starts. No Grub. No change. No FC5. Oooo-kkkkkk. Windows sees the 102MB partition on the PATA as active, but pulling the drive makes no change - XP still works, no FC5.
 
Try again, this time leaving Grub to be where it wanted - /dev/hde MBR. Same, no FC5, XP boots.
 
So I have an FC5 install that I can get to with a rescue disk and I can probably then make a boot floppy to boot FC5, but I would like to see Grub working properly.
 
I had bad experiences a year or so ago with FC4 on the PATA as a single drive, as Grub stopped me getting into XP entirely - hence the new drive, XP on the SATA, and the PATA now just for FC5.
 
Any ideas how I can get this working?

Participate on our website and join the conversation

You have already an account on our website? Use the link below to login.
Login
Create a new user account. Registration is free and takes only a few seconds.
Register
This topic is archived. New comments cannot be posted and votes cannot be cast.

Responses to this topic



data/avatar/default/avatar10.webp

2895 Posts
Location -
Joined 2002-08-30
Well, your situation possibly is a little unique. It seems that Linux has some troubles with the ITE8212 interface. I found two articles on the subject, one located here specifically speaks to the issue.
 

Quote:it wants to install the Grub to the MBR of /dev/hde. Change that to be MBR on /dev/sda (as the first booting drive), install, reboot, and XP starts. No Grub. No change. 
I assume that you used the custom disk partitioning scheme when you did this? Otherwise, generally, you would get two choices, the begining of the boot sector on the installed drive, or the MBR. Otherwise, If you used the "advanced configure bootloader" checkmark under the custom partition layout section, you don't see these options.
 

Quote:Windows sees the 102MB partition on the PATA as active, but pulling the drive makes no change - XP still works, no FC5. 
You mean that you pulled the pata drive? This will, of course, not work for two reasons. One is that grub needs to reference some files on the pata drive, and need the drive itself present to load the system.
 

Quote:Try again, this time leaving Grub to be where it wanted - /dev/hde MBR. Same, no FC5, XP boots. 
This will not work either. the grub bootloader is still on the pata drive, not the boot drive.
 
This system, besides having the unusuall pata interface rather than a standard IDE port, has some complex bios settings to consider. If you take a look at the users manual, under the bios section, you will see what I mean. There are several comments about setting the bios correctly with multiple drives in the system.
 
 


data/avatar/default/avatar30.webp

4 Posts
Location -
Joined 2006-06-27
OP
Thanks Danleff for your response.
 
"It seems that Linux has some troubles with the ITE8212 interface"
 
I have had linux running (FC4) successfully on this PC before on the PATA drive on the IT8212, but not dual boot. Installs and runs fine. I have it there cos it's an ATA133 interface.
 
"I assume that you used the custom disk partitioning scheme when you did this?"
 
Yes - when it came up with the options as being only /dev/hde MBA or the boot sector of that drive I ticked the advanced bootloader box to get the option to change the order of the drives, thus giving me the option to install Grub to the MBA of /dev/sda, which is the primary boot drive set in BIOS.
 
Should I:
 
1. Boot to FC5 rescue, chroot /mnt/sysimage and grub-install /dev/sda to try and force a grub reinstall on the SATA?
 
or
2. Change the BIOS order to boot from the PATA first (where Grub is from the last FC5 install). This will then basically how I had it when I had FC4 - PATA as boot disk, Grub in the MBA. If I do this I assume I will have to change boot.ini drive numbering as the SATA where XP is will no longer be the same reference (I have an XP boot floppy disk on which I can change boot.ini and get into XP), and I assume also I will need to reconfigure Grub to find XP again as it will have 'changed' locations?
 
TIA....
 

 


data/avatar/default/avatar10.webp

2895 Posts
Location -
Joined 2002-08-30
Quote:I have had linux running (FC4) successfully on this PC before on the PATA drive on the IT8212, but not dual boot. Installs and runs fine. I have it there cos it's an ATA133 interface.

That's exactly the difference. Linux did not need to interact with essentually three different interfaces, ITE8212, IDE {traditional pata) and sata. I assume that when FC4 was et up on the system, this drive was the first in the boot order and/or perhaps there was no sata drive in the system?

What Fedora and grub try to do is "guess" the correct designation of your drives, based on the bios settings on boot. Your system has some complex series of settings that can be made to detect drives on the system. If you in fact did tell FC5 to install to the MBR of the sata drive, and it did not, then this interactin is what I am referring to. If you boot straight into XP with the sata drive set first, then the MBR was not written over.

The article that I referenced, the author ran into problems with this. He gave up and ditched the ITE8212 interface. I bet a bios setting needs to be adjusted to get it to work properly.

Quote:Should I:

1. Boot to FC5 rescue, chroot /mnt/sysimage and grub-install /dev/sda to try and force a grub reinstall on the SATA?

You can try this, but you may end up with booting errors, much like the author of the article did, due to the ITE8212.

Quote:or
2. Change the BIOS order to boot from the PATA first (where Grub is from the last FC5 install). This will then basically how I had it when I had FC4 - PATA as boot disk, Grub in the MBA. If I do this I assume I will have to change boot.ini drive numbering as the SATA where XP is will no longer be the same reference (I have an XP boot floppy disk on which I can change boot.ini and get into XP), and I assume also I will need to reconfigure Grub to find XP again as it will have 'changed' locations?

Yep, you are correct. Or, you can try "reverse mapping" in grub, which will fake out the bios order and change the logical order back to having sata first. Usually the commands are something like;

title Windows XP (or "other" in the original config.)
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd0,0)
chainloader +1

But, of course, this depends on how the drives are seen in your /boot/grub/device.map file.

Any reason why you don't want Fedora on the sata drive with dual boot?


data/avatar/default/avatar30.webp

4 Posts
Location -
Joined 2006-06-27
OP
"I assume that when FC4 was et up on the system, this drive was the first in the boot order and/or perhaps there was no sata drive in the system?"
 
Yup - correct. No other drive, PATA only.
 
OK, did my number two option. PATA is now primary boot drive, so Grub came up and booted Fedora. Tried its option for XP - as expected did not work. Tried my XP boot disk, no joy there, but edited its boot.ini from multi(0)disk(0)rdisk(0)... to read multi(0)disk(0)rdisk(1)... and off it went. Booted into XP and edited its boot.ini so now all set for when Grub points there. Current Grub.conf reads:
 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hde
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15-1.2054_FC5smp)
root (hd0,0)
kernel /vmlinuz-2.6.15-1.2054_FC5smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.15-1.2054_FC5smp.img
title Windows XP
rootnoverify (hd1,0)
chainloader +1
 
What do I need to change to get Grub to boot Windows on the SATA which is now at multi(0)disk(0)rdisk(1)...? I'm asssuming it's something to do with the rootnoverify (hd1,0) chainloader +1 lines?
 
/boot/grub/device.map:
 
# this device map was generated by anaconda
(hd0) /dev/hde
(hd1) /dev/sda
 
Windows XP is on /dev/sda1 - so why does (hd1,0) not work?
 
"Any reason why you don't want Fedora on the sata drive with dual boot?"
 
I like keeping them separate - bad experiences in the past I guess trying to dual boot on one drive with earlier versions of grub, and also for space.
 
BTW thanks for your help so far - your advice and comments are very helpful. You obviously know your stuff... I have three MCSEs and 10 years on MS but Linux is new to me....


data/avatar/default/avatar10.webp

2895 Posts
Location -
Joined 2002-08-30
Hmmm... I don like this. Want to throw caution to the wind?
 
Get into a terminal window, as root user. Type in;
 
grub-install --recheck /dev/hde
 
NOT hde1
 
Hit the enter key.
 
See if XP and Fedora will now boot. It looks like the drive mapping was off, where hde (the IDE drive) was mapped first. If Fedora boots, but XP does not, report back what error or result that you got.
 
You can also try changing the boot.ini back to the original value for rdisk and try again.


data/avatar/default/avatar30.webp

4 Posts
Location -
Joined 2006-06-27
OP
Thanks danleff - did that as per your instructions. Output was 'no errors', device mapping remained unchanged - floppy as /dev/fde, PATA as /dev/hde and SATA as /dev/sda. No difference - FC5 boots fine, XP sits at a screen saying:
 
Windows XP
rootnoverify (hd1,0)
chainloader +1
 
That reflects the boot order in BIOS though - the PATA is first, as per the change I made in an earlier reply to get Fedora booting at all. So as I figure, the PATA is now hd0, the SATA is hd1, and XP is on the first partition on hd1 SATA, so hd1,0 I assume. This is also reflected by the boot.ini rdisk setting needing to be 1 for my XP boot disk. If that is the case, Grub should bootstrap XP when it points to hd1,0 i'da thunk! ??? The boot sectors on the SATA are obviously fine, as if I take out the PATA, BIOS sets the SATA as boot disk and off it boots into XP! Weird...
 
Incidentally I had to type /sbin/grub-install... etc. Does that mean /sbin/ is not in my 'path'?