SUSE 5019 Published by

A zabbix update has been released for SUSE Linux Enterprise 15:

openSUSE-SU-2024:0064-1: moderate: Security update for zabbix




openSUSE-SU-2024:0064-1: moderate: Security update for zabbix


openSUSE Security Update: Security update for zabbix
_______________________________

Announcement ID: openSUSE-SU-2024:0064-1
Rating: moderate
References: #1219775
Cross-References: CVE-2024-22119
CVSS scores:
CVE-2024-22119 (NVD) : 5.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVE-2024-22119 (SUSE): 5.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Affected Products:
openSUSE Backports SLE-15-SP5
_______________________________

An update that fixes one vulnerability is now available.

Description:

This update for zabbix fixes the following issues:

- CVE-2024-22119: Fixed a stored XSS in graph items select form
(boo#1219775).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2024-64=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 i586 ppc64le s390x x86_64):

zabbix-agent-4.0.50-bp155.3.12.1
zabbix-java-gateway-4.0.50-bp155.3.12.1
zabbix-phpfrontend-4.0.50-bp155.3.12.1
zabbix-proxy-4.0.50-bp155.3.12.1
zabbix-proxy-mysql-4.0.50-bp155.3.12.1
zabbix-proxy-postgresql-4.0.50-bp155.3.12.1
zabbix-proxy-sqlite-4.0.50-bp155.3.12.1
zabbix-server-4.0.50-bp155.3.12.1
zabbix-server-mysql-4.0.50-bp155.3.12.1
zabbix-server-postgresql-4.0.50-bp155.3.12.1

References:

https://www.suse.com/security/cve/CVE-2024-22119.html
https://bugzilla.suse.com/1219775