Debian 9899 Published by

The following updates has been released for Debian GNU/Linux:

[DLA 1030-1] vim security update
[DLA 1031-1] evince security update
[DSA 3914-1] imagemagick security update



[DLA 1030-1] vim security update

Package : vim
Version : 2:7.3.547-7+deb7u4
CVE ID : CVE-2017-11109
Debian Bug : #867720


Vim 8.0 allows attackers to cause a denial of service (invalid free) or
possibly have unspecified other impact via a crafted source (aka -S)
file.

For Debian 7 "Wheezy", these problems have been fixed in version
2:7.3.547-7+deb7u4.

We recommend that you upgrade your vim packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

[DLA 1031-1] evince security update

Package : evince
Version : 3.4.0-3.1+deb7u1
CVE ID : CVE-2017-1000083
Debian Bug : 868500

from the Google Security Team discovered that the Evince document
viewer made insecure use of tar when opening tar comic book archives
(CBT). Opening a malicious CBT archive could result in the execution
of arbitrary code. This update disables the CBT format entirely.

For Debian 7 "Wheezy", these problems have been fixed in version
3.4.0-3.1+deb7u1.

We recommend that you upgrade your evince packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

[DSA 3914-1] imagemagick security update

- -------------------------------------------------------------------------
Debian Security Advisory DSA-3914-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
July 18, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : imagemagick
CVE ID : CVE-2017-9439 CVE-2017-9440 CVE-2017-9500 CVE-2017-9501
CVE-2017-10928 CVE-2017-11141 CVE-2017-11170
CVE-2017-11360 CVE-2017-11188
Debian Bug : 863126 867367 867778 867721 864273 864274 867806 868264
868184 867810 867808 867811 867812 867896 867798 867821
867824 867825 867826 867893 867823 867894 867897

This updates fixes several vulnerabilities in imagemagick: Various
memory handling problems and cases of missing or incomplete input
sanitising may result in denial of service, memory disclosure or the
execution of arbitrary code if malformed RLE, SVG, PSD, PDB, DPX, MAT,
TGA, VST, CIN, DIB, MPC, EPT, JNG, DJVU, JPEG, ICO, PALM or MNG
files are processed.

For the oldstable distribution (jessie), these problems have been fixed
in version 8:6.8.9.9-5+deb8u10.

For the stable distribution (stretch), these problems have been fixed in
version 8:6.9.7.4+dfsg-11+deb9u1.

For the unstable distribution (sid), these problems have been fixed in
version 8:6.9.7.4+dfsg-12.

We recommend that you upgrade your imagemagick packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/