Ubuntu 6281 Published by

A CUPS security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, and 23.04.



[USN-6391-1] CUPS vulnerability


==========================================================================
Ubuntu Security Notice USN-6391-1
September 20, 2023

cups vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

CUPS could be made to crash or run programs if it opened a specially
crafted file.

Software Description:
- cups: Common UNIX Printing System(tm)

Details:

It was discovered that CUPS incorrectly parsed certain Postscript objects.
If a user or automated system were tricked into printing a specially
crafted document, a remote attacker could use this issue to cause CUPS to
crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
cups 2.4.2-3ubuntu2.5

Ubuntu 22.04 LTS:
cups 2.4.1op1-1ubuntu4.7

Ubuntu 20.04 LTS:
cups 2.3.1-9ubuntu1.6

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6391-1
CVE-2023-4504

Package Information:
https://launchpad.net/ubuntu/+source/cups/2.4.2-3ubuntu2.5
https://launchpad.net/ubuntu/+source/cups/2.4.1op1-1ubuntu4.7
https://launchpad.net/ubuntu/+source/cups/2.3.1-9ubuntu1.6