Ubuntu 6347 Published by

A FAAD2 security update has been released for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, and 20.04 LTS.



[USN-6313-1] FAAD2 vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6313-1
August 29, 2023

faad2 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in FAAD2.

Software Description:
- faad2: Freeware Advanced Audio (AAC) Decoder

Details:

It was discovered that FAAD2 incorrectly handled certain inputs. If a user or
an automated system were tricked into opening a specially crafted input file,
a remote attacker could possibly use this issue to execute arbitrary code.
(CVE-2021-32272, CVE-2021-32273, CVE-2021-32274, CVE-2021-32277,
CVE-2021-32278, CVE-2023-38857, CVE-2023-38858)

It was discovered that FAAD2 incorrectly handled certain inputs. If a user or
an automated system were tricked into opening a specially crafted input file,
a remote attacker could possibly use this issue to cause a denial of service.
(CVE-2021-32276)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
faad 2.9.1-1ubuntu0.1
libfaad-dev 2.9.1-1ubuntu0.1
libfaad2 2.9.1-1ubuntu0.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
faad 2.8.8-1ubuntu0.1~esm1
libfaad-dev 2.8.8-1ubuntu0.1~esm1
libfaad2 2.8.8-1ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
faad 2.8.0~cvs20150510-1ubuntu0.1+esm1
libfaad-dev 2.8.0~cvs20150510-1ubuntu0.1+esm1
libfaad2 2.8.0~cvs20150510-1ubuntu0.1+esm1

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
faad 2.7-8+deb8u3ubuntu0.1~esm1
libfaad-dev 2.7-8+deb8u3ubuntu0.1~esm1
libfaad2 2.7-8+deb8u3ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6313-1
CVE-2021-32272, CVE-2021-32273, CVE-2021-32274, CVE-2021-32276,
CVE-2021-32277, CVE-2021-32278, CVE-2023-38857, CVE-2023-38858

Package Information:
https://launchpad.net/ubuntu/+source/faad2/2.9.1-1ubuntu0.1