Ubuntu 6416 Published by

A PHP security update has been released for Ubuntu Linux 22.04 LTS and 23.04.



[USN-6305-1] PHP vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6305-1
August 23, 2023

php8.1 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.04 LTS

Summary:

Several security issues were fixed in PHP.

Software Description:
- php8.1: HTML-embedded scripting language interpreter

Details:

It was discovered that PHP incorrectly handled certain XML files.
An attacker could possibly use this issue to expose sensitive information.
(CVE-2023-3823)

It was discovered that PHP incorrectly handled certain PHAR files.
An attacker could possibly use this issue to cause a crash,
expose sensitive information or execute arbitrary code.
(CVE-2023-3824)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
libapache2-mod-php8.1 8.1.12-1ubuntu4.3
php8.1 8.1.12-1ubuntu4.3
php8.1-cgi 8.1.12-1ubuntu4.3
php8.1-cli 8.1.12-1ubuntu4.3
php8.1-fpm 8.1.12-1ubuntu4.3
php8.1-xml 8.1.12-1ubuntu4.3

Ubuntu 22.04 LTS:
libapache2-mod-php8.1 8.1.2-1ubuntu2.14
php8.1 8.1.2-1ubuntu2.14
php8.1-cgi 8.1.2-1ubuntu2.14
php8.1-cli 8.1.2-1ubuntu2.14
php8.1-fpm 8.1.2-1ubuntu2.14
php8.1-xml 8.1.2-1ubuntu2.14

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6305-1
CVE-2023-3823, CVE-2023-3824

Package Information:
https://launchpad.net/ubuntu/+source/php8.1/8.1.12-1ubuntu4.3
https://launchpad.net/ubuntu/+source/php8.1/8.1.2-1ubuntu2.14