Ubuntu 6321 Published by

An object-path security update has been released for Ubuntu 18.04 LTS and 20.04 LTS.



USN-5967-1: object-path vulnerabilities


=========================================================================
Ubuntu Security Notice USN-5967-1
March 22, 2023

node-object-path vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in object-path.

Software Description:
- node-object-path: Access deep object properties using a path

Details:

It was discovered that the set() method in object-path could be corrupted
as a result of prototype pollution by sending a message to the parent
process. An attacker could use this issue to cause object-path to crash.
(CVE-2020-15256, CVE-2021-23434, CVE-2021-3805)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
node-object-path 0.11.4-2ubuntu0.1

Ubuntu 18.04 LTS:
node-object-path 0.11.3-1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5967-1
CVE-2020-15256, CVE-2021-23434, CVE-2021-3805

Package Information:
  https://launchpad.net/ubuntu/+source/node-object-path/0.11.4-2ubuntu0.1
  https://launchpad.net/ubuntu/+source/node-object-path/0.11.3-1ubuntu0.1